cancel
Showing results for 
Search instead for 
Did you mean: 

FBM Operation Program Group

Valued Contributor
Valued Contributor

Hello there,

 

I am working on NX 10.0.3.5 FBM. I have a problem in operation program group.

 

For example, I have some tapping machining rules for different features (different features use different tapping rules). In each of them, I added the following line to make these operations fall into the program group of "TAP"

 

oper.PROGRAM_ORDER_GROUP= "TAP"

 

In NX, before I used Feature Based Machining to Create Feature Process, I created a program group called "TAP" manually, as I created some operations manually before. After Creating Feature Process, some tapping operations fell into that "TAP" group, while some fell into an automatically created new group called "TAP_1". 

 

This also happened to other kinds of operations, such as CHMFR_MILL, SEMI_MILL, and so on (the groups were named by myself).

 

I was wondering how I can make sure the same kind of operations fall into the same program group.

 

Thanks,

Kai

3 REPLIES

Re: FBM Operation Program Group

Esteemed Contributor
Esteemed Contributor

The program groups must be in the correct machining order, if this is not the case, then FBM creates another program group to maintain the correct machining order.

This is new since NX 10, in previous NX releases this was not the case.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: FBM Operation Program Group

Valued Contributor
Valued Contributor

Hello Stefan,

 

Thanks for your reply. Is there a way that I can turn off this option? Because the order in which we machine workpieces on the machine is different from the order in which we define the machining rules?

 

Thanks,

Kai

Re: FBM Operation Program Group

Esteemed Contributor
Esteemed Contributor

This is no option and cannot be turned off.

In previous NX releases the order in the geometry view was checked, starting with NX 10 the order in all ONT views must match.

You need to correct your rules to always create the operations in the correct order, to do this, you might just have to change the priority of some rules.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Learn online





Solution Information