Showing results for 
Search instead for 
Do you mean 
Reply

FBM with NX Custom

Hi All,

I am trying to use FBM with Rob Cohon's NX Custom application.  It works fine when I do the step to find features.  NX creates features in the Machining Feature Navigator.  When I highlight a featue and select "Create Feature Process", I get an error that says "Feature Process Generation Failed".  If I do the same steps using NX10 that is installed locally on my machine, it creates the feature process without any issues.  I have attached a screen shot of the information window and also a section of the log file that seems to be related to the fbm error I am getting.

 

Any ideas on what I need to do to make FBM work using Rob Cohon's NX Custom Application?

 

Thanks in advance,

Kurt Francis

NX 10.0.2.6 MP4

 

 

7 REPLIES

Re: FBM with NX Custom

The log files images doesn't tell us what we need to know.

 

The information window image tells you that there was no solution found.

 

To see what the problem is, open the information window before you select "Create feature process", you will then see a listing of the process application and where it fails.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: FBM with NX Custom

Stefan,

Thank you for the response.  I did as you instructed and opened the information window before selecting "Create Feature Process".  I have attached a picture of the complete information window listing.  It seems like it errors out right away.

Re: FBM with NX Custom

Hi Kurt,

 

We'll need to have a look at your NX syslog for further clues.

Can you please share that?

 

Tom van 't Erve

NX CAM development

Re: FBM with NX Custom

Tom,

My syslog is attached.

Re: FBM with NX Custom

Hi Kurt,

 

The syslog does provide some leads but no immediate "smoking gun" yet.

I will need to drill down with one of the key developers in this area and hope to get back to you in a few days.

 

Tom van 't Erve

NX CAM Development

Re: FBM with NX Custom

Hi Kurt,

 

The problem must really be in your configuration.

We tried it with NX Custom without any difficulties.

 

The syslog does hint to an issue that we fixed in NX10.0.3; but it's just a hint; no guarantee.

Would you be able to test your NX Custom workflow with NX10.0.3?

 

Tom van 't Erve

NX CAM Development

Re: FBM with NX Custom

I tried the workflow using 10.0.3 with the same results.  I will see if I can identify what the issue is with my configuration and report back if I find anything.

Learn online





Solution Information