Cancel
Showing results for 
Search instead for 
Did you mean: 

Facing problem in proper motion of Machine Axis in Machine Simulation

Valued Contributor
Valued Contributor

Hi all

I have build my custom machine using the post buider. In simulation when M128 code executes all of 5 axis overlimits and my machine shows wierd behaviour.

For details i am posting a video here.

(view in My Videos)

My cutting path lies only on the workpart as shown in this image.

Machine files and all necessary files are also attached here. Please some do work on it and tell me where i made mistake. If possible then please share me the solution also. thanks


Cutting Tool Path.JPG

4 REPLIES

Re: Facing problem in proper motion of Machine Axis in Machine Simulation

Gears Phenom Gears Phenom
Gears Phenom

I think your X is reversed on the video.

C - I dont see direction because of graphics clearly.

 

Maybe you have also something wrong with zero point because machine moves far away from the part.

Or maybe some issue with units mm/inch? Because small program steps moves machine components to much.

---------------------------------------------
#♫ PB, 5ax, itnc, nx, vericut ♫ #

Re: Facing problem in proper motion of Machine Axis in Machine Simulation

Pioneer
Pioneer

Hi,

I have started with a 3 axis model for customizing post process file.I am beginner at the ISV and post configurator integration.

I have a problem same as your problem.Limits of Y and Z axis is different. Tool simulation is good but machine simulation is different.How it can be? I think this is coming from pui or tsl files or something like that.

But experts must show us a way.

Re: Facing problem in proper motion of Machine Axis in Machine Simulation

Valued Contributor
Valued Contributor

@drafter006

 

I think we must have to edit .MCF through machine configrator. In my PC nx doesn't start machine configrator as it returns an error while loading machine configrator" Machine configrator is not installed"

 

I will fix this problem first then work on .MCF later. See what will happen.

Re: Facing problem in proper motion of Machine Axis in Machine Simulation

Pioneer
Pioneer

Hi aagha,
For combination of ISV and Post, I started to 3 axis mill. I thought this could be simple and basic
step for me.

Some problems occured.Axis movements was wrong.I have builded kinematic again. But I did not use 3axis base assembly model of NX. I put without junctions assembly model under my 3axisfanuc model.Machine Zero caried to spindle center. And I defined axis limits.X-Y and Z axis limits determined according to Machine Zero. I tested all axis zero points.

 

And ToolChange program changed like this
(Set the tool change position values in metric X,Y,Z)
#100001=0.0
#100002=0.0
#100003=0.0
(Position for the V axis to mount the tool)
#100004=-381.0
(Z Position over the tool changer)
#100005=50

 

And .ini file content changed.

(This part sets the position of the reference point G28)
G54

(Implement the setting of the reference point unit dependent)
G10L52
N1240P1R0000
N1240P2R0000
N1240P3R0000
G11

 

And machine simulation is OK. I do not know how did I fixed?

Finally I will examine codes with ISV.I am happy.

 

Unable to play video. Please try again later.
(view in My Videos)

Learn online





Solution Information