Cancel
Showing results for 
Search instead for 
Did you mean: 

Geometry does not update as per template part

Pioneer
Pioneer

Hi All,

I have created a part which I want to use as a template. Lets say "Template_part.prt"

In this part,I have set the Geomtery as "MCS_SPINDLE" and have added facing operation under it.

I have selected botht he options for "Template Settings" for the "MCS_SPINDLE".

 

When I open a new part file and browse for this template, I am able to find the template part "Template_part.prt" witht he facing operation listed under it.

 

however, the issue is that the Geomtery is set to "NONE" instead of "MCS_SPINDLE" in facing operation. rest of values are correct.

 

Is there anyt setting that I have to do in order to make it work.

 

Thanks,

Faisal Ahmed

11 REPLIES

Re: Geometry does not update as per template part

Esteemed Contributor
Esteemed Contributor

 

however, the issue is that the Geomtery is set to "NONE" instead of "MCS_SPINDLE" in facing operation. rest of values are correct.

 


When you say "NONE", where are you seeing it?

In the dialog creating a new operation?

after the operation is added?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Geometry does not update as per template part

Are you using the part as a setup templae or to create an operation?

What is "Create if prent is Created" on the operation?

Mark Rief
Retired Siemens

Re: Geometry does not update as per template part

Pioneer
Pioneer

Apologise for delayed response!

 

It is "NONE" after the operation is added.

 

Thanks,

Faisal Ahmed

Re: Geometry does not update as per template part

Pioneer
Pioneer

Apologise for delayed response.

 

I am using this as template part to create operations.

the intent is to use the operations from template rather than creating every time.

 

I tried to use "Create if prent is Created" option, it doesnt work for "Geomtery".

I was able to successfully use "Create if prent is Created" for Method but not for Geomtery.

 

Thanks,

Faisal Ahmed.

Re: Geometry does not update as per template part

Esteemed Contributor
Esteemed Contributor

Make sure that your objects are not inside of the "unused objects" group else they will be discarded.

In addition all parents up to the root object must have the "create if parent is created" box checked.

To force this do as follows:

  1. select all objects
  2. select template settings from the context menu
  3. switch at least once to the opposite of the two settings
    • this is to make sure all objects inherit the correct settings, since the display is not displaying the state of all objects, but that of the majority
    • if you do not toggle the state to the opposite and back to what you want, you will get mixed states
  4. hit OK
  5. save and close your template
  6. try again

Hope this helps.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: Geometry does not update as per template part

When you want the operations created, which of these are you doing?

  1. Create setup
  2. Create operation
  3. Create geometry

They can all create operations - it is important to understand which you are using.

Mark Rief
Retired Siemens

Re: Geometry does not update as per template part

Pioneer
Pioneer

Hi Mark, I am not creating a setup. Just operation, Geometry and Method

For better clarity, I will describe the process I am doing.

1) Create a new part

2) Crete new operation in it (Lets say Rough Turning Operation named: "Operation A")

3) This operation to have a Geometry, Method, Tool and other parameters defined.

4) The Geometry, Method, Tool can be custom created in the part or default NX provided.

Let us assume at this time that "Geometry = MCS_SPINDLE" (Default NX provided), "Method = Custom_Rough" (created by me).

5) Tick both the options in Template Settings

6) Save and close the part (Let us say TemplatePart.prt)

7) Open a new part -> Create Operation -> In template type, browse the "TemplatePart.prt" and select the operation listed in it ("Operation A").

 

At this point, I expect all the settings present in the "Operation A" to get carried into new operation that I am creating.

 

This is where I have two issues

1) The New operation dialog that pops up doesnt have the settings from Operation A (Let us ignore this for a moment)

2) When I click OK, the new operation has all the parameters correct including the custom method I created but the Geomtery inside the operation is incorrect.

 

Hope this answers your question.

Re: Geometry does not update as per template part

Esteemed Contributor
Esteemed Contributor

If you create an operation from a template, then the parents are selected from the currently open part. This is why you have to select them in the create operation dialog.

If you create a geometry from a template, then the contained operations are copied from the template part, if the members are set to "create with parent".

This is how it is designed to work.

If you need an exact copy of the template part file, you must create a "File => New" template.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: Geometry does not update as per template part

Pioneer
Pioneer
Great! Thanks for the response.
I will revert for more clarification if needed.

Learn online





Solution Information