cancel
Showing results for 
Search instead for 
Did you mean: 

How to IGNORE any segment in a TOOL PATH (TURNING)

Pioneer
Pioneer

Is there any option allow me to ignore the RED segment in that tool path in turning?

I tried to use IGNORE MEMBER in CUSTOM PART BOUNDARY DATA for that segment, but it doesn't work. It still machines the whole path, so I have to create 2 OD Operation to skip that area. Maybe I don't use that function properly. Anyone please help ! I'm much appreciated.

 

 photo Untitled_zpsm2zkn6qf.jpg

8 REPLIES

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Try adding a stock value for this Boundary Member

But then, in Cut Regions you should switch Region Machining to Multiple

Marek Pawlus, NCmatic

Production: NX 11.0.2
Development: C#, Tcl/Tk, CSE

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Pioneer
Pioneer

Succeeded! Thank you so much Marek!

 

I'm still wondering how IGNORE MEMBER work? why it doesn't work in this case?

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

if you upload part file, we can take a look

Marek Pawlus, NCmatic

Production: NX 11.0.2
Development: C#, Tcl/Tk, CSE

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Master
Master
I have found that ignore member also didn't work on my parts that have a groove in a bore and I just wanted to go straight through the bore in one move. I had to add face stock to get this to work. Interested in the answer to this.
Shags72 Mfg. Eng.
Windows 7 Pro 64bit
NX 8.5.2.3 MP3 Teamcenter 8
Dell M6700 i7-3740QM 8GB RAM,
NVIDIA Quadro k3000M

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Esteemed Contributor
Esteemed Contributor

Shags -

Did you already rough out the groove, or not?

As long as I haven't cut the groove, I've usually been able to get the "ignore member" to work, but there's occasions where it is "strange".

If I have already roughed the groove, then you need to add blank stock, otherwise NX knows it's cutting air & doesn't want to cut across it.

But then I'm on NX7.5, so I'm hoping (ha!) that it will be fixed in NX10

 

I'm thinking the "ignore member" is really meant to ignore several curves in the boundary.  In the case of a groove, this works well (there is a clear start & end member, and a clear way for NX to "bridge the gap"

But in the original poster's issue, I think he just wants to ignore ONE curve, so that may not work (how is NX supposed to bridge the gap?)

 

Another option might be ut use point containment with 2 vectors.  Point would be just to right of top end of curve, one vector straight down, one pointing to left.

 

Ken

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Master
Master

Ken,

Ya the groove has been cut already and the bore is being finished after heat treat. I tried to ignore members of the groove but it didn't work so l ended up adding stock. So you have gotten ignore to work?

Shags72 Mfg. Eng.
Windows 7 Pro 64bit
NX 8.5.2.3 MP3 Teamcenter 8
Dell M6700 i7-3740QM 8GB RAM,
NVIDIA Quadro k3000M

Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Esteemed Contributor
Esteemed Contributor

I usually can get it to work, but if I encounter a groove that has been cut, the same issue as you encountered happens, because there is no stock there in the IPW.  Note the functionality is "ignore boundary members", not "put stock back into the IPW"

 

Occasionally I have issues if the top of the groove has fillets, the "ignore members" does strange things.  But as I said, I'm hoping 10 fixes this.

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: How to IGNORE any segment in a TOOL PATH (TURNING)

Master
Master

Oh I see, looking at the preview it looks to skip the groove. This is why I thought it was ignoring the members between the start and end selections. I thought that GTAC had told me that this would work but doesn't.

Shags72 Mfg. Eng.
Windows 7 Pro 64bit
NX 8.5.2.3 MP3 Teamcenter 8
Dell M6700 i7-3740QM 8GB RAM,
NVIDIA Quadro k3000M

Learn online





Solution Information