cancel
Showing results for 
Search instead for 
Did you mean: 

How to post using GPM with cls files in Nx10

Creator
Creator
Need help on post processing using GPM in nx 10,
It work well when there is no ugii_env.dat file define
And the opposite way that when i have ugii_env.dat file set in system enviroment, the post show error cls2clf not found. Any one can help?
5 REPLIES

Re: How to post using GPM with cls files in Nx10

Creator
Creator
 

Re: How to post using GPM with cls files in Nx10

Esteemed Contributor
Esteemed Contributor

In NX7.5, I had to create a separate gpm_env.dat in the ...\MACH\auxiliary folder, as GPM doesn't support some stuff found in the "main" one used by the NX session (IIRC nested "#if" statements are the problem).

Then I had to write a .bat to be called instead of the actual GPM.exe, to define UGII_ENV_FILE

 

But now that NX10 is out, I can't get the interactive Menu -> Tools ->CLSF dialog to work, so (rather than reporting an IR) I told the users that GPM was dead (note using it thru GRIP still seems to work) and they had to use the UGpost posts instead.

 

Ken

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: How to post using GPM with cls files in Nx10

GPM is not supported.

It went on critical maintenance in 2003 and the retirement was announced in 2010.

 

But if you want to try it, the files you need (including gpm_env.dat) can be found in the mach\auxiliary folder from an 32 bit NX 8.5 installation.

Mark Rief
Retired Siemens

Re: How to post using GPM with cls files in Nx10

Creator
Creator

Hi Ken & Mark

 

Appreciate for your answer as during this period i an doing system testing for gpm but i still could'nt get it correct.

 

I understand that GPM is obsoleted but we have mass old files which running GPM all the time and i need gpm to support those old files while have version update and going forward to ugpost.

 

I am using Grip to call GPM all the time and run well.

Unfortunately when i set the environment UGII_ENV_FILE to a share drive so that i could do customization, it seen that GPM is unable to run properly due to directory issue.

(cls2clf not found)

( this issue happen since nx7.5 where ugii_env_file don't work with GPM)

 

OUTPUT CLSF seem to be working with nx10 so far, please guide me if there an unseen issue to use output clsf.

 

is there any way to have GPM in the customization folder as well, so that it still accessible to nx10 grip for our mass old files which running GPM all the time. 

 

can it be achieve with gpm_env.dat?

To be more specific, can i know which variables affecting GPM and what the files structure should be in the customise file?

eg. ...\nxcustom\GPM\...

gpm.exe

gpm.ico

gpm_env.dat

mdfg.bat

mdfg.ico

mdfg.exe

cls2clf.bat

cls2clf.exe

cls2clf.ico

iso.voc

apt.voc

bcl.voc

 

Thanks for Help

Charles

Re: How to post using GPM with cls files in Nx10

Esteemed Contributor
Esteemed Contributor

This stuff is in the \mach\auxiliary\ folder tree.

 

So move that folder & all contents to your customized area, add the files you need, and then set

UGII_CAM_AUXILIARY_DIR

appropriately

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Learn online





Solution Information