cancel
Showing results for 
Search instead for 
Did you mean: 

Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

Hi

I've seen the discussion related to this problem. but what if the license server is ok (other installations works), but on one station I receive the same error? Any ideas. I've uninstalled / installed the NX 8.5 on that one station, but the same "Unknown error 948956". Please help.

11 REPLIES

Re: Launching NX8.5 generates "Unknown error 948956"

Esteemed Contributor
Esteemed Contributor

Might be the Windows firewall was not allowed to unblock communication, there is usually a dialog requesting permission for the network to communicate with the license server on the first start of NX.

Have you tried running lmutil to check the connection?

Run the following from a command prompt.

"%UGII_BASE_DIR%\ugflexlm\lmutil" lmstat -i -c %UGS_LICENSE_SERVER%
Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

thank you for your reply.

the connection works. It detects P1, NX11110 v.29.0 and also others.

The firewall on that station is deactivated all the time.

 

Re: Launching NX8.5 generates "Unknown error 948956"

Esteemed Contributor
Esteemed Contributor

Whenever a client has a license problem, the FIRST thing to check (if you can) is the license server log file.

If there are NO records from the client PC or user, then the issue is somewhere on the client (not on network or network is down, firewall blocking traffic, ENV variable pointing at wrong server, etc.)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

indeed, the license server log contain no record related to the client in discussion.

however, the firewall on the client side is down and the env variable point to the right server (the lmutil command with %UGS_LICENSE_SERVER% detects the server and the available licenses).

Re: Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

to continue:

- other stations run NX8.5 without any problems.

- on the problem station, NX7.5 works just fine, but NX8.5 doesn't.

 

please help

Re: Launching NX8.5 generates "Unknown error 948956"

Esteemed Contributor
Esteemed Contributor

On the client, try starting NX, then look at the syslog

- If NX comes up, Something like "Help -> NX Log file" or "Help -> Log file"

- if NX does not come up, it will be "%TMP%\%USERNAME%(gibberish).syslog"
("gibberish = random letters/numbers, e.g. "25d83f98")

 

If you can, post the syslog here, or send it to GTAC to see if they can figure it out.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

thank you for the info, Ken.

I can now say that (I don't now why) nx try to get the license from the SolidEdge license server running on the problem machine, despite the fact that UGS_LICENSE_SERVER is pointing to the right server (another reachable machine).

please help

Re: Launching NX8.5 generates "Unknown error 948956"


alextripcea wrote:

thank you for the info, Ken.

I can now say that (I don't now why) nx try to get the license from the SolidEdge license server running on the problem machine, despite the fact that UGS_LICENSE_SERVER is pointing to the right server (another reachable machine).

please help


Where is SPLM_LICENSE_SERVER pointing? I believe that is used from NX 8.5 forward.

Mark Rief
Retired Siemens

Re: Launching NX8.5 generates "Unknown error 948956"

Creator
Creator

same as UGS_LICENSE_SERVER

Learn online





Solution Information