cancel
Showing results for 
Search instead for 
Did you mean: 

NX 11 Do not support for Drlling

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

I installed NX 11, but i didn't see drill template for operation . Please tell me why that not enough

9 REPLIES

Re: NX 11 Do not support for Drlling

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

HoleMaking....

Re: NX 11 Do not support for Drlling

Esteemed Contributor
Esteemed Contributor

If I remember correctly, the What's New guide of NX 11 CAM mentions, that P2P from the drill template is no longer recommended to be created.

The preferred way is to use the hole_making => drilling operations.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: NX 11 Do not support for Drlling

Experimenter
Experimenter
you can turn it back on by opening the "cam_general.opt" file in the "template_set" folder and remove the comment from the "## ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}drill.prt" line

Re: NX 11 Do not support for Drlling

Valued Contributor
Valued Contributor
Go here: C:\Program Files\Siemens\NX 11.0\MACH\resource\template_set. Open up cam_general.opt in notepad. Then remove the ## from the line that says:
## ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}drill.prt

Save the file and reload NX. Make sure you have write access first.

Hope this helps.

Re: NX 11 Do not support for Drlling

Valued Contributor
Valued Contributor
You can try my first post but I actually think this is the solution so try this first.
Go to C:\Program Files\Siemens\NX 11.0\MACH\resource\template_dir and open the Template.dat file in Notepad.
Copy ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}drill.prt into the line you use most. I only 001 general so as an example my line would look like:
DATA | 001| general.| ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_planar.prt| ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_planar.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_contour.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_multi-axis.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_multi_blade.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}mill_rotary.prt
${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}drill.prt
${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}hole_making.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}turning.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}wire_edm.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}probing.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}solid_tool.prt ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}work_instruction.prt | General | Inch

Yours will read in a single line left to right. Place the ${UGII_CAM_TEMPLATE_PART_ENGLISH_DIR}drill.prt where you want to show up in the order of operations.

Make sure you have write access and save the file.

Restart NX. It may or may not integrate into a previous model you are working with. It should though.

Hope this helps.

Re: NX 11 Do not support for Drlling

Experimenter
Experimenter

Here is the release notes about the drill.prt

Capture.PNG

Re: NX 11 Do not support for Drlling

Experimenter
Experimenter

Once you've removed the ## from the line in the opt file you can just go to Manufactuing Preferences and under the configuration tab click the 2 reset arrows and the drilling operations will show up again.

Capture.PNG

Re: NX 11 Do not support for Drlling

They are hidden intentionally, so that new users do not use them. If you need to maintain ole programs, then you can expose them, but you should not be using them for new work.

Please read the release notes with each new release.

Mark Rief
Retired Siemens

Re: NX 11 Do not support for Drlling

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Thanks you so much, 

Learn online





Solution Information