cancel
Showing results for 
Search instead for 
Did you mean: 

NX Post Feedrate

Experimenter
Experimenter

Greetings All,

 

Using Generic Motion, Custom feed rate for the cut motion is not getting output at correct block.

Tried with all the variables in the list.

 

Please help me to get it done..

6 REPLIES

Re: NX Post Feedrate

mom_custom_feed should be getting set. Have you looked at the review tool?

Mark Rief
Retired Siemens

Re: NX Post Feedrate

Experimenter
Experimenter

Greetings,

 

There are no variable exists with that name of mom_custom_feed.

 

In Generic motion operation we can add 'move to point' as we want with option of 

motion type and feed type. Change in the feed should output automatically.

 

I checked with review tool no variable has the new feed rate.

 

 

 

Re: NX Post Feedrate

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

What version of NX are you using?

What type of motion are you having an issue with?

I have been using generic motion and have not seen any issues with custom feeds not being output, as long as they are different values than the previous motion.\

John Joyce, Manufacturing Engineer,
Senior Aerospace Connecticut
www.senioraeroct.com
Production: NX11.0.2.7, Vericut 8.0.3
Development: Tcl/Tk

Re: NX Post Feedrate

Phenom
Phenom

You are correct that custom feeds are not put in any global data (variable) so there is no way to see it in the post. All versions I have tested (up to 8.5) are this way. By this I mean "Motion Type -> Cut and Feed Rate Type -> Custom." I tell people they can't use custom feeds - and set one of the feed types to the feed they want instead. I have not reported it to GTAC. It is surprising that there has been little mention of it here. Maybe Generic Motion operation is not used much.

NX10.03
Windows 7 Pro

Re: NX Post Feedrate

I just tried this to be sure, and I see my custom feed on each cut move.

 

N530 G1 X-10. M8 F111.
N540 X25. F222.
N550 X-190. Y-35.35534 Z21.2132 C180. F333.
N560 G0 X-10.

 

Please either provide more information, or contact GTAC to figure this out.

Mark Rief
Retired Siemens

Re: NX Post Feedrate

Phenom
Phenom

Version 10? If so - good to know it has been fixed. Version 7.5, 8.5 (just checked) - with "mill3ax" post - I put in cut/custom/1.2345 and get F10. I have done MOOG_Show_Globals looking for the value - nothing. Also - "mom_custom_feed" is not a current global variable at that point in posting (the linear move in question.)

NX10.03
Windows 7 Pro

Learn online





Solution Information