cancel
Showing results for 
Search instead for 
Did you mean: 

NX10 - Memory leak

Experimenter
Experimenter

Dear NX-users,

 

For school I use NX 10.0.3 MP8 on my ZBook 15 G3-mobile workstation with NVIDIA Quadro M2000M 16 GB.
After I open a setup-file (Manufacturing), my memory use increases from a couple MB to the maximum capacity (ca. 15,9 GB) in about ten minutes. The next thing that happens is that NX freezes and my workstation crashes.

 

I tried to look up the latest certified driver for this version on Windows 10 but nothing seems to work.
Does anyone here have experience with this issue and a possible solution?

 

Thank you in advance!

Kind regards,
Wouter

PS: Other students use other laptops/workstation and have the same problem! I have contacted HP about this matter, but after three months they didn't manage to come up with a working solution...

18 REPLIES

Re: NX10 - Memory leak

Legend
Legend

You should install MP12

 

NX11.0.1

Re: NX10 - Memory leak

Experimenter
Experimenter

Thanks for the tip! Can you direct me to a link where to do that?

 

EDIT: I don't have a WebKey account. The licence server is on our school.

Re: NX10 - Memory leak

Experimenter
Experimenter

I just installed the update (MP12), the issue isn't fixed.

The RAM-usage starts to increase to its max as soon as I'm in Manufacturing-mode...

 

Re: NX10 - Memory leak

Esteemed Contributor
Esteemed Contributor

Is it an issue in a part file?

Try doing part cleanup (file -> Utilities -> part cleanup)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX10 - Memory leak

Experimenter
Experimenter

No, it's not a part issue, it happens with every setup file (as soon as I switch to Manufacturing).

 

Re: NX10 - Memory leak

Esteemed Contributor
Esteemed Contributor

Well, normally I'd say you should contact GTAC.  Be prepared to send them some log files, part files, etc.

But I'm not sure if student or educational licensed users can contact GTAC?

 

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX10 - Memory leak

Is this using the out of the box setup templates?

Does this happen after creating the setup, with no additional action? Or only after you start inserting operations? If so, what kind of operations?

What is the part size and the IPW needle counts?

Mark Rief
Retired Siemens

Re: NX10 - Memory leak

Experimenter
Experimenter

Hi MarkRief,

 

It happens with all setup files, some of them are made using the box of templates and are referenced to a part. When I model a new simple part, there are no problems with the RAM usage, but when I create a setup file referenced to this new part, the memory starts to increase rapidly without doing any operation. (in fact, even when I don't do anything at all)

 

The average part file sizes I use are between 1 tot 20 MB at most.

I attached two screenshots (one at startup and one after 12 minutes) and my log file.

 

PS: I upgraded to NX 10.0.3 MP12, so this isn't my latest log-file, but the problem still exists.

 

 

Re: NX10 - Memory leak

@BrabersW this does not sound familiar at all to our developers. To diagnose, you will need to log a call with GTAC so that they can investigate.

Mark Rief
Retired Siemens

Learn online





Solution Information