cancel
Showing results for 
Search instead for 
Did you mean: 

NX10 Zlevel Profile Engage

PLM World Member Builder PLM World Member Builder
PLM World Member Builder

We just updated to NX 10.0.1.4

 

When working with Zlevel profile if I set my closed area and open area engage to none and set my initial open area engage to liner, generate and ok the operation and save. Then when i post it or regenerate it my open area engage automatically turns back on to liner and invalidates my operation.

 

Any else see this or can duplicate it?

TJ

5 REPLIES

Re: NX10 Zlevel Profile Engage

Esteemed Contributor
Esteemed Contributor

I'd report to GTAC.

Note 10.0.2 is out there (and some MPs for it), you might want to try downloading & testing to see if it fixes your issue. (note 10.0.3 is coming soon)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX10 Zlevel Profile Engage

I don't see the problem in NX 10.0.2 MP4.

As a workaround, try [OK]ing the operation first, then edit it and generate.

 

zl_ncm.jpg

Mark Rief
Retired Siemens

Re: NX10 Zlevel Profile Engage

PLM World Member Builder PLM World Member Builder
PLM World Member Builder

I just updated to 10.0.2 MP3 (i didn't see MP4 on the download site)

 

still the same issues. i have it set just like you show below, gernerate and ok the opeation, then when i open the operation (right click, edit) as soon as i do that it turns invalid and when i open non cutting moves open area is set to linear again instead of none

Re: NX10 Zlevel Profile Engage

Esteemed Contributor
Esteemed Contributor

I don't know the part, but I expect that an engage of none is really dangerous.

Might be a security setting to have not both set to none.

 

How about setting only one to none and referencing this from the other one, like open area = none, closed area = use open area?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: NX10 Zlevel Profile Engage

PLM World Member Builder PLM World Member Builder
PLM World Member Builder

Stefan, let me clarify, I usaully set closed area to "same as open area" and then open area to "none" and in this situation i have an initial open area set to linear but we very comonly have no engagement sent. We have very large and old machines and if you have an engage move it will leave a dwell mark even with single block off becuase they are slow and compute the moves slow. We will usually extend edges or draw lines to follow for an engage move. We have a saying in the shop that NX makes the hard stuff easy (contours, pockets, ect) and the easy stuff hard (planar milling or prismatic cuts, we use manual mill a lot because its the only way to get the desired path!).

 

I attached an example part with the path in question. As its saved the engage moves are set to the following.

- Closed area = same as open area

- Open area = none

- Initail closed = same as initial open area

- Initail open = linear, 1in, 90, 0, .1, 0

 

But as soon as i open the operation it goes invalid and the open area changes to linear, see if it does the same for you.

Learn online





Solution Information