Cancel
Showing results for 
Search instead for 
Did you mean: 

NX12.0.1 MP1: Fix for occasional Tcl error

Siemens Genius Siemens Genius
Siemens Genius

Hi everyone, 

 

a few of our users report errors when using NX12.0.1 with the latest MP1, and see an error similar to this, when trying to post process a part program: 

2018-05-17 10_09_46-Output.png 

This error is then given in the syslog:

***TCL_ERROR***: Event Handler: D:\Siemens\NX 12.0\mach\resource\library\machine\installed_machines\sim08_mill_5ax\postprocessor\sinumerik_PostConfigurator\sim08_mill_5ax_sinumerik.tcl, Event: MOM_end_of_program, Error: wrong # args: should be "info exists varName"

    (procedure "info" line 27)

    invoked from within

"info exists tclSeenPath($dir)"

 

We are investigating the origin of this error, but it only happens to few installations, and seems to be caused by the way Tcl8.6 loads packages. We will provide a solution with the next available fix. 

 

In the meanwhile, there is a fairly easy to implement workaround, that you can use, in the case you are seeing the error happening in your NX installation: 

 

  1. Clear the ready-only attribute and open the following file in a text editor of your choice:
    ...\NX 12.0\MACH\auxiliary\tcl\library\tcl8.6\init.tcl
  2. Add the following lines to the very end of this file:
    # This line is needed to avoid package loading error in TCL8.6 for some installations
    set calltime [clock format [clock seconds] -format {%T} -gmt 0]

     

  3. Save your changes, and re-apply the read-only attribute to it

 

This should fix this problem for the moment. If that error still persists, please reach out to us, or file a PR with GTAC. 

 

I am sorry for the inconvinience, 

Florian Weisse

3 REPLIES

Re: NX12.0.1 MP1: Fix for occasional Tcl error

Valued Contributor
Valued Contributor

Hi @FlorianW,

 

This fixes problem on my computer, but another one pops out an error like this one (something with the clock again)

 

I'm attaching relevant part of syslog.

 

Is this a known issue?

 

(EDIT: Problem gone, thanks to "MP2" or "not forgetting set read-only again"? IDK)

Re: NX12.0.1 MP1: Fix for occasional Tcl error

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Is this problem resolved in NX12.0.1 MP02?

A college of mine is stil having this problem in MP02...

Sven Voeten
Pre-sales NX CAM / Manufacturing Consultant
cards PLM Solutions

Re: NX12.0.1 MP1: Fix for occasional Tcl error

Valued Contributor
Valued Contributor

This problem seems to be not solved in MP2. But you can still use stated workaround.

 

BTW, to anyone reading my earlier post: our all workstations are problem free now.

 

Thanks.

Learn online





Solution Information