Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

NX8.5 geometry not driving B axis

In NX drilling operations our MEs are selecting the Geometry from the top of the Operation dialogue window. This geometry then drives the B axis through the post by the value in mom_out_angle_pos(0). This is good.

 

However they are also inserting an operation Mill Control -

Taken from template_part\metric\mill_planar.prt

Operation Sub-type "Mill Control"

 

Again the geometry is chosen at the top of the dialogue window.

However the mom_out_angle_pos(0) for B axis is always 0.0 regardless of the Geometry chosen.

So any GOTO added in this dialogue now makes this an Initial Move and puts out a G0 B0.0, regardless of the geometry specified?!

 

Is there a reason that this geometry window does not alter the value for mom_out_angle_pos(0)?

 

Thanks in advance.

Craig.

4 REPLIES

Re: NX8.5 geometry not driving B axis

How are you specifying the angle in the geometry?

Has the GOTO UDE the tool axis vector set in the operation?

 

I assume the GOTO overwrites the setting of the geometry by its own tool axis vector definition.

 

Have checked the inheritance of the operation?

Did you use the review tool during post-processing to check what the values are set to at any stage?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: NX8.5 geometry not driving B axis

Stefan,

 

The part is a hydraulic component with a lot of intersecting holes. There are a lot of new WCS geometries created within NX for the various operations.

 

If we select one of these geometries in the Drilling dialogue -

When posted the review tool then shows mom_out_angle_pos(0) is 90 in the MOM_initial_move event and the resultant B axis move is to B90.0.

 

However if we add a template operation of type "Mill Control" and select a geometry in the same manner as above the mom_out_angle_pos(0) is always 0. So when posted the MOM_initial_move event would drive the B to 0.0!!

 

Solution
Solution
Accepted by topic author cs3672
‎12-10-2015 04:37 AM

Re: NX8.5 geometry not driving B axis

Mill_Control (and Lathe/Wire EDM control) operations can sometimes behave strangely when posting (I've also seen issues with initial & first move events).

 

My suggestion would be to try to use a different operation type.  For milling, maybe "Generic motion", for turning, try "Teach mode"

 

If you like to have fun writing tcl files (or don't have licenses for the above operation types) I also use legacy PTP drill cycles with the "Standard Text" cycle, and then have my own handler for MOM_drill_text_move (I'm on NX7.5 right now so I haven't been able to play much with Holemaking)

 

For holemaking you can also define your own cycles in a CDL file (I've seen people do it, but have not yet had time to play with it myself).

 

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX8.5 geometry not driving B axis

What type of geometry is G15_H110_B90 and what is changed or added compared to a newly created geometry of this type?

 

Not all operation type inherit all settings from all parent objects, so there is more detailed information needed.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Learn online





Solution Information