cancel
Showing results for 
Search instead for 
Did you mean: 

Operation Start of Path Events after First Move??

Pioneer
Pioneer

Hey guys,

 

NX8.5

TURN mode.

 

I'm having problems with an NX Operation.

We have various commands in an NX Operation "Start of Path Event", but when posted out these are being output AFTER the MOM_first_move?!

As far as I am aware this should not happen. All Object Start of Path Event UDEs should be output before Initial Move or First Move??

This is a second NX Operation with no tool change required as it's the same tool as the previous operation.

If I make this the first Operation the output order changes and the Start of Path UDEs come out before the Initial Move?

 

I do not understand what would make the Start of Path Events come out AFTER the First Move though, even though it's a second operation with no tool change? That should not matter.

 

Any help would be appreciated.

Craig.

5 REPLIES

Re: Operation Start of Path Events after First Move??

Esteemed Contributor
Esteemed Contributor

Since this involves multiple files of your configuration, it is hard to help.

One would need the following files to duplicate the issue:

  1. sample part file
  2. post processor used
  3. any additional files like custom UDE library

Without those files no one is able to help.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: Operation Start of Path Events after First Move??

Esteemed Contributor
Esteemed Contributor

What is the list of UDEs?
Do you have any "*_Marker" UDEs? (Tool_Change_Marker, Start_Marker, etc.)?

Are either of the operations "Lathe Control" operations?

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Operation Start of Path Events after First Move??

Legend
Legend

Hi,
Usually all UDEs work before initial and first move.
I guess you have this situation because of use of FROM point. Moreover it happens not only in turn mode, but in mill mode. In this situation the from move becomes first move, but UDE come out only after it, before second move (which is actually first move of the path).

From.JPG

Re: Operation Start of Path Events after First Move??

Esteemed Contributor
Esteemed Contributor

From moves are (typically!) not output in posts.

However, your post might be different - Look in the post

"Program and Tool Path" -> "Program" -> "operation Start Sequence" -> scroll down to find "From Move" - is there anything there?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Operation Start of Path Events after First Move??

Phenom
Phenom

Yes - looks like another thread stated the same thing:

 

https://community.plm.automation.siemens.com/t5/Discussion-Forum-NX/order-of-event/m-p/327518

NX10.03
Windows 7 Pro

Learn online





Solution Information