Cancel
Showing results for 
Search instead for 
Did you mean: 

Post Builder - XZC mill turn missing C value

Valued Contributor
Valued Contributor

When I create PP by post builder, I found only NX6 version can generate correct tool path.

I got missing C value when using NX9 and NX11 post builder. (See attachment)

 

Does anyone have the same problem?

 

Thanks

 

Terry

7 REPLIES

Re: Post Builder - XZC mill turn missing C value

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

I'd report this to GTAC.

Otherwise you'll have to dig into the tcl code...

 

 

Does your machine have G12 / G112 / G12.1 / other forms of Polar Interpolation (Okuma G137, IIRC Siemens TRANSMIT)?

Most people prefer to use that than directly outputting C axis angles (if you ran correct code with what you're doing, you would probably notice "linear" surfaces have a "faceted" look, whereas with polar interpolation, they will look smooth)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Post Builder - XZC mill turn missing C value

Valued Contributor
Valued Contributor
Hi Ken,
Our machine is Okuma b300II, I have not studied the G137 yet, I will study this G code if it help.

Thanks a lot

Terry

Re: Post Builder - XZC mill turn missing C value

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Yes, on Okumas, I only use G136 (what you were outputting) for drill cycles (if that).

G137 creates a "virtual" Y axis (tool stays on X axis CL, but the control does the interpolation between the points, moving X & C(rotary) rather than NX)

G138 uses (if available) the physical Y axis.  Note if you have a physical Y axis on the machine, there may still be cases you want to use G137, as on a lot of the Okumas (at least the ones we have) the Y axis travel is limited to the point a lot of parts HAVE to use G137 to cut them.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Post Builder - XZC mill turn missing C value

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

Hi My friends,

 

Please help me explain me how to use TCL to swow XC coordinates

 

I am develping a post procesos for a Mill Turn EMCO with Sinumerik 840D sl, 

 

Best Regards.C axis.jpgC missing some lines

Re: Post Builder - XZC mill turn missing C value

Experimenter
Experimenter
Go to cutting perameter > more > cut step ..... change the value of 30% to 1-2mm.... now regenerate the program and post process... see the output

Re: Post Builder - XZC mill turn missing C value

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter
Sorry, I cant find cut step in cavity mill

[cid:94a909ca-5aa5-4cc9-ae0b-7f32e91ff257]


Atentamente,



Msc. Ing. Andrés Freile

Gerente General



Cel: 0998019575

Tel: +593-02-2 667 - 222/ 3 103 - 027/ 2 653 - 995

Mail: andres.freile@techdesign.com.ec / andresfreilea@hotmail.com





Quito-Ecuador

www.techdesign.com.ec



Síguenos en: FACEBOOK

Re: Post Builder - XZC mill turn missing C value

Experimenter
Experimenter

which virsion of nx are u using?

Learn online





Solution Information