Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Post processor is not rotating C axis 180 degrees for drilling cycles

I started the post from the MILLTURN standard post from NX. When my holes are less than 180 degrees apart I get the following code for my drilling cycle

 

G181 X.675 Y0.0 I0.0 F2. C0.0

C-90.

C-180.

C-270.

G80

 

 

 

Then I took out one hole out of my cycle and get the following.

 

G181 X.675 Y0.0 I0.0 F2. C0.0

C90.

X-.675 C90.

G80

 

Has anybody run into this issue and know how to correct this.

 

Using NX 8.0.3.4
9 REPLIES

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

[ Edited ]

try uncommenting the first and the second commented lines in PB_CMD_revise_new_iks

 

revise_new_iks.png

hope it works.

ciao

 

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

Unfortunately not.Smiley Sad

Using NX 8.0.3.4

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

sorry, I don't have the post and the part, so cannot try, have you tried this?

alwayspositive.PNG

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

I think lead you to look at the incorrect post processor. I think I toof the millturn_baxis_5axis post. It is a 5 axis post with a head-table machine. I kind of need that one because my tool vector can be at any "B" angle due to my adaptive tool fixturing.

Using NX 8.0.3.4

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

I thought the post was MillTURN XZC template.
For this operation the tool axis is perpendicular to C table or there is a B angle?

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

I just did some testing on the post and saw that the b axis and not the C is moving 180 degrees. I realized that it is completely valid for the head to rotate 180 or the Table to rotate 180 to get to that position. If the angle is anything other than 180 then the C-axis has to move to get to that location.  I made the post output mom_pos(3) and it was 180.

 

So it seems not I have to somehow disable the B axis from rotating. I haven't done a post processor for a while, so I am not sure how.

 

 

Using NX 8.0.3.4

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

since the C axis must rotate 180 and probably the B axis rotates a smaller angle, the post chooses this second possibility and moves B and X.
Solution
Solution
Accepted by topic author aluminum2
‎06-17-2016 12:37 PM

Re: Post processor is not rotating C axis 180 degrees for drilling cycles

[ Edited ]

One method I have seen used is to reset the B axis limits depending on (by using the operation type or UDE or whatever)

This will "force" the post to use the correct location, assuming you can come up with valid limits.

 

Assuming "B" is the 4th axis:

  set mom_kin_4th_axis_max_limit                "1.0"

  set mom_kin_4th_axis_min_limit                "-1.0"

 

(if not, use "5th")

 

(edited in...)

And you'll need a "MOM_reload_kinematics" after setting the limits

Note (If possible) you want to do this in an event BEFORE the initial / first move events (once you get to the initial or first move events, the positions are already calculated, so you would have to re-calculate them)

Ken

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Post processor is not rotating C axis 180 degrees for drilling cycles

 

Only by changing the machine  parameters and adding the following code I was able to output the C axis rotation. For some strange reason, the kinematics want to place the b axis at 270 degrees instead of -90 even though it is the same location. Or so I think. It works for the drill cycle. I feel there still are demons in with this and feel I have more code to write. At least now it seems I know the direction to go. Thanks everybody for the help.

 

global mom_kin_4th_axis_min_limit  mom_kin_4th_axis_max_limit

set mom_kin_4th_axis_max_limit                "90"
set mom_kin_4th_axis_min_limit                "-90"

MOM_reload_kinematics

mahsetup.jpg

Using NX 8.0.3.4

Learn online





Solution Information