Showing results for 
Search instead for 
Do you mean 
Reply

Running out of RAM and page file ignored.

[ Edited ]

My computer has 32GB of ram which is more than enough for the type of work I do but recently I had three sessions of NX running; two sessions were generating large rest milling operations, one was generating operations on a smaller part and I eventually ran out of RAM.  As the RAM was approaching full usage I assumed the page file would be utilised and I thought the operations were almost complete so I did not anticipate the generation taking much longer.  However, when the RAM maxed out, I received an Out of Memory dialog for each session of NX so apparently NX did not use any of the paging file at all and the operations were obviously not completely finished generating.  These operations were generating for almost three hours so that set me back a while.  I restarted everything and this time I am generating just one session of NX this time and it is running as I write this post.

 

Are there any preferences, customer defaults or variables I should be using so NX uses the page file?

NX 11.0.2
2 REPLIES

Re: Running out of RAM and page file ignored.

You might get some help from this article in the GTAC Solution Center on NX Workstation Hardware Selection Criteria, which discusses page file use. 

Mark Rief
Retired Siemens

Re: Running out of RAM and page file ignored.

The article did not say much about it but I think I may have found a solution.

 

I noticed my page file size was set to a range and the initial size was quite small.  I would think the size would be dynamic when specifying a range but I do not know for sure so I set it to system managed size.  I did a quick test and so far it seems to be working.

NX 11.0.2

Learn online





Solution Information