cancel
Showing results for 
Search instead for 
Did you mean: 

Setting up a specific M70 command in MCF

Creator
Creator

Hi all,

 

I have a question which hopefully someone might be able to assist with.

 

I am configuring an MCF file for a specific machine with a Siemens 840D control, and I am trying to configure an M70 command, which on the physical machine is set with an = like this:

 

M70=71

M70=72

 

My problem is that I can't get this to be read by the MCF, it appears to be ignoring it when it is in this format (i.e. no error, no processing of any code that is against the M70). 

 

If I program M70 on its own I end up in the expected place and can get code to process. Am I doing something wrong? I believe I've set it up in the same way as other similar codes, e.g. M2 (M2=3 for example).

 

I'm using NX9.0.2.5.

 

Any help much appreciated.

 

 

2 REPLIES

Re: Setting up a specific M70 command in MCF

Siemens Phenom Siemens Phenom
Siemens Phenom

When a M meta code is not part of the MCF it will be ignored by default.

We don’t want to force to enter any M code and ignore them for simulation.

Now to your point:

 

M70=71 creates a meta code M71 with the value of 70

M70=72 creates a meta code M72 with the value of 70

Same as Sinumerik controller will do.

 

Hope it helps

 

2017-03-09 14_21_46-XML Notepad - C__Users_schulz_AppData_Local_Temp_re_mc_tp_1489065625945.xml.png2017-03-09 14_22_00-NX 11 - Manufacturing - [sim05_mill_5ax_cam_sinumerik_mm.prt (Modified) ].png

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: Setting up a specific M70 command in MCF

Creator
Creator

Hi Thomas,

 

This would explain the behaviour. I was not aware that this was how the 840d consumes these codes.

 

Thanks for your assistance! Smiley Happy

Learn online





Solution Information