cancel
Showing results for 
Search instead for 
Did you mean: 

Sourcing TCL warning message

Valued Contributor
Valued Contributor

I am sourcing in TCL in to my posts and I deleted all the old commands and replace them with procs from the sourced file. now everytime I try to edit a PB command I get a warning saying that the referenced proc has not been defined and it may be assumed it is an existing data element. When running the post it runs fine. It is just annoying because I get the warning message in a lot of spots when editing or savinf the post. Is there an easy way to get past this.

Using NX 8.0.3.4
5 REPLIES

Re: Sourcing TCL warning message

Esteemed Contributor
Esteemed Contributor

What exactly did you delete?

 

When I use external (sourced) procs, what I do is...

In the POST (postbuilder) I have:

proc PB_CMD_Moog_Do_Something {} {
    # comments
    Moog_Do_Something   ;# Call sourced proc
}

 Never had a problem with this, although I don't remember if I ever tried PB 8.0.3 (I'm skipping directly from PB7.5.x to 9.0.x)

Ken

 

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Sourcing TCL warning message

Does it look something like this? I get this all the time.  I made a thread on it here http://community.plm.automation.siemens.com/t5/Discussion-Forum-NX/Scope-of-procedures-in-post-build...

 

Capture.JPG

Jake Hardwick
CNC Programmer
Senior Aerospace AMT
Production NX8.5.3.3 Beta testing NX10.0.1.4

Re: Sourcing TCL warning message

Valued Contributor
Valued Contributor

Yeah I do get the above. From what I gather you saved it then re-opened it and it fixed the issue for you?

Using NX 8.0.3.4

Re: Sourcing TCL warning message

Phenom
Phenom

In PB8.5.1 - I see:

 

Options -> Validate Custom Commands -> Unknown Commands

 

This stops the proc check. As far as having it know the proc exists in the sourced file - I don't know of a way.

NX10.03
Windows 7 Pro

Re: Sourcing TCL warning message

Valued Contributor
Valued Contributor

yeah, unchecking it stopped it. Thanks.

Using NX 8.0.3.4

Learn online





Solution Information