Cancel
Showing results for 
Search instead for 
Did you mean: 

Tool Change: <Command grasp called with invalid argument>

Experimenter
Experimenter

Hey

 

I have a problem wit the simulation of my kinemtic model. When I press play there is the message "Command grasp called with invalid argument" and the tool wasn't loading.

 

The tool is defined and also think the kinematic model is defined right. But I'm really not shure at all. The ToolChang program is copied from the  folder sim010101_002_mm. I only changed the the first position. I'm not shure if this is actually allowed or what I have to rewrite in this file.

 

In the Attachement i added a picture of my error.

Thanks for your help.

 

Franky

2 REPLIES

Re: Tool Change: <Command grasp called with invalid argument>

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

You need a tool mount junction named "S" to make this work.

 

In addition the axis named "S" is not a NC axis, since it is not a positional axis.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.1, FBM, MRL 3.1.7 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 11.4
Development: C (ITK), .NET, Tcl/Tk Testing: NX12.0 | AWC 3.4 Preparing: NX12.0

Employees of the customers, together we are strong Smiley Wink
How to Get the Most from Your Signature in the Community
NX Customization - Best Practice Guide

Re: Tool Change: <Command grasp called with invalid argument>

Experimenter
Experimenter

Thank you, thank you, thank you ... that was really helpfull. my simulation is working now Smiley Very Happy

Learn online





Solution Information