cancel
Showing results for 
Search instead for 
Did you mean: 

cannot get a Thru coolant code for lathe post

Pioneer
Pioneer

When I left-mouse-click the "Coolant" event in "Machine Control" I only have "ON", "Flood" and "Mist" as available M Codes, when I right-mouse-click on "Coolant" and choose "Edit" "User Defined Parameters" and then right-mouse-click on "Type" and choose "Edit", I see the option for "Thru" in the list. I have tried all kinds of things to get this code to come out to no avail.

 

In my mill posts this is not the case, the M Code for "Thru" is available in the "Machine Control" events and the through coolant codes work fine. I would sure appreciate some help on this; it doesn't seem like it should be difficult to do but so far it has proven otherwise.

 

Thanks in advance,

Gary

5 REPLIES

Re: cannot get a Thru coolant code for lathe post

Esteemed Contributor
Esteemed Contributor

Not surprisingly, the answer is "it depends"

Primarily on where the UDE list is coming from.

Are these separate posts, or linked posts in a mill-turn?

Does (either) post have the (NC Data definitions -> Other Data Elements -> "Include other UDE CDL file" checked, and what file(s) do they point to?

Or the "Inherit UDE from a post" or "include own CDL file" set?

 

If none of the above, then it is coming from the CAM config file (e.g. "CAM_general.dat")

look in that file dor the line that starts "USER_DEFINED_EVENTS" - that has the UDE.CDL file in use.

 

It could be you're using an old CDL file ("thru" was added in NX7.5 or so, or at least sometime after NX4).

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: cannot get a Thru coolant code for lathe post

Pioneer
Pioneer

Hello Ken,

 

Thank you for your reply. It is not a linked post, it is just a stand-alone 2-axis lathe post. 

 

"Include other CDL File" is checked, it is pointing to   $UGII_CAM_USER_DEF_EVENT_DIR/ude.cdl and from the Log file I can see that is pointing to my sandbox area that has the "resource" folder copy from the original install MACH folder as was suggested by Mark Reif in one of his CAM Customization videos. I have a custom milling cycle in that ude.cdl file in my sandox and NX sees it so I can be sure that is the file and folder it is looking at.

 

When I open that ude.cdl file with my text editor I see:

 

#---------------------------------------------------------------------------
EVENT coolant
{
POST_EVENT "coolant_on"
UI_LABEL "Coolant On"
CATEGORY MILL DRILL LATHE

PARAM command_status
{
TYPE o
DEFVAL "Active"
OPTIONS "Active","Inactive","User Defined"
UI_LABEL "Status"
}
PARAM coolant_mode
{
TYPE o
DEFVAL "Flood"
OPTIONS "On","Flood","Mist","Tap","Thru"
UI_LABEL "Type"
}
PARAM coolant_text
{
TYPE s
TOGGLE Off
UI_LABEL "Text"
}
}

 

which is pretty standard stuff, I believe. My mill posts that DO have the Thru coolant are also looking at this same ude.cdl and that is what is baffling me. Why do they work and not this lathe post?

 

Of course there is also a .cdl file in the directory where this particular posts lives, I really don't quite understand the relationship between the two, but, the coolant section in it is identical to what I pasted in above so again, it seems that it should be working.

 

I am running version 9, I first started out with version 8 and made this post somewhere along the way, I am almost certain I made it after I installed 8.5

 

Tnanks again,

Gary

Re: cannot get a Thru coolant code for lathe post

Phenom
Phenom

I think the person that made the 2 axis lathe template did not anticipate a need for thru coolant. The first sign of this is that there is no M code setting in postbuilder for thru - where there is with a mill post. The M code setting inside postbuilder decide what of the following are in the tcl:

 

set mom_sys_coolant_code(MIST) "7"
set mom_sys_coolant_code(ON) "8"
set mom_sys_coolant_code(FLOOD) "8"
set mom_sys_coolant_code(OFF) "9"

 

So - since there is not one for THRU you get nothing. If in a custom command in start of program - you define "mom_sys_coolant_code(THRU)" maybe you will get it.

NX10.03
Windows 7 Pro

Re: cannot get a Thru coolant code for lathe post

Esteemed Contributor
Esteemed Contributor

There is a new option available in the tool dialogs, that allows to specify through cooling on the more tab of a tool.

This is available since NX 8.5 at least.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: cannot get a Thru coolant code for lathe post

Pioneer
Pioneer

Thanks, I have a custom command that runs right at the beginning of the program so I added:

 

global mom_sys_coolant_code

set mom_sys_coolant_code(THRU) 51

 

and that works fine using the built-in logic.

 

Gary

Learn online





Solution Information