Showing results for 
Search instead for 
Do you mean 
Reply

cutter comp post output

Ok so I'm getting frustrated with NX. I have a post file that needs a little tweaking. Something that would seem easy, but apparently not so much. Ok so when posting multiple operations with cutter comp I get a result that does not include the dia offset for any of the remaining operations. It also ignores the lead in for the current operation and instead sends the tool (at cut depth) directly to the very first lead in location. no matter what is in the way. (Catastrophe ensues) I'm ready to beat my head on the wall here.

Does anyone have a clue what I can do to fix it?

 
G0E1X2.8757Y4.3345
G43H12Z4.
M1
M8
S10000.2M3
Z.5
Z.061
G1Z-.0391F30.
D12
G41
Y4.5064
X2.8422Y4.5031
X2.8099Y4.4933
X2.7802Y4.4775
---------------------------
X2.8757Y4.1627
G40
Y4.3345
Z.061
G0Z.5
X3.8442Y3.8093
Z.061
G1Z-.0391
G41X2.8757Y4.3345 XY same as blue line above
X3.8442Y3.9811 Should be the same as this Y value

4 REPLIES

Re: cutter comp post output

To get the D on every G41/G42 line

Create a custom command (PB_CMD_Torg_Cutcom_On)

In it have a call (this assumes your register word is called "D")

MOM_force once D

 

In PB, go to the "cutcom on" event, add that custom command.

 

Now every time cutcom is turned on, D will be output (assuming mom_cutcom_adjust_register is defined)

 

Re: The move issues: How are you turning cutter comp on? (and what operation type?)

- Non cutting moves -> More tab -> Cutcom

- "Cutter Compensation" UDE?

 

Ken

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: cutter comp post output

[ Edited ]

None cutting moves more tab. Although I have tried ude as well with same result.

 

 

Most of the time i am using the cavity mill operation..

Sent from my iPhone

Re: cutter comp post output

 im hoping my post hasnt gotten lost in the shuffle.

Re: cutter comp post output

[ Edited ]

Goign with what Ken_A recommended, I added a Custom command to the CutCom section in Postbuilder.

 

My Linear move in Postbuilder looks like this:

I turn cutter comp on in the non-cutting moves in my operation:

 

My toolpath looks like this:

 

Here is my output:

 

G00 G90 G54 X.7584 Y.5615 T01
G43 H01 Z2. M08
Z.03
G01 Z-.07 F7.3
G41 X.7459 Y.5831 D01 <------ first pass cut_com_on
G03 X.6315 Y.1563 I.1563 J-.2706
G02 X.6315 Y-.1563 I-.2706 J-.1563
G01 X.4511 Y-.4688
----------------------------
G01 X.6315 Y.1563
G03 X1.0584 Y.0419 I.2706 J.1563
G01 G40 X1.0459 Y.0635 <---- .025 cut_com_off move
Z.03
G00 Z.22
X.7584 Y.5615
Z-.16
G01 Z-.26
G41 X.7459 Y.5831 D01 <----- diameter adjustment is output on subsequent passes
G03 X.6315 Y.1563 I.1563 J-.2706

 

Hope this solves your problem or at least puts you on the right track.

 

NX 8.5.3.3

Learn online





Solution Information