cancel
Showing results for 
Search instead for 
Did you mean: 

export to library error

Experimenter
Experimenter

Hello,

 

I'm trying to edit an OD turning tool in NX9.0 from the tool library. After I edit the choices in the dialog box (insert shape, position and so on), I click export to library.  I get asked "Do you wish to replace it or create a new cutter?" I click create, i select my od_turning in the target class, and get the error "unable to update file".

 

Can anyone help with this, much appreciated.

 

Thanks,

Rolando

8 REPLIES

Re: export to library error

Esteemed Contributor
Esteemed Contributor

Do you have write permission to the folder where the library resides?

If you don't have your CAM customization placed in a separate structure to have it update save and writable, you should do so.

Read the "NX Custom" threads for your NX release about the best practice to customize NX.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: export to library error

Experimenter
Experimenter

Stefan

I have write permissions. 

I'm not sure what you mean by CAM customization being placed in a seperate folder.  Can you help me out with this please.

regards

 

 

Re: export to library error

Esteemed Contributor
Esteemed Contributor

Try it, and when you get the error, go to the NX log file (Menu -> Help -> Log file)

Go  to the bottom and search up to see if there is anything more specific (i.e. what file it was trying to write to)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: export to library error


Rolando wrote:

Stefan

 

I have write permissions. 

 

I'm not sure what you mean by CAM customization being placed in a seperate folder.  Can you help me out with this please. 

 


If you are nut using Teamcenter, then when you export a tool, it is modifying a file - tool_database.dat. If you modify the one from Siemens, you risk loosing your edits when you update the software. To get started, take a look at Getting started with NX CAM customization

Mark Rief
Retired Siemens

Re: export to library error

Experimenter
Experimenter

Mark,

 

I watched the NX customization video (very helpful).  I edited the ugii_env.dat file and created the resource, usertools and bitmap folders.  I launched NX from my shortcut and opened the log file.  the paths to the folders I created are not shown but all my CAM folders show the new path. Attached is the log file.

 

path location error.JPG

Re: export to library error

There is no log file - just a picture of part of it. Is the ugii_env.dat file in the "start in" folder of your shortcut?

If so, I would need to see the env and syslog text files - not pictures.

Mark Rief
Retired Siemens

Re: export to library error

Experimenter
Experimenter

Mark,

 

Yes, the ugii_env.dat file is in the "start in" folder.

 

attached are syslog text file and the .dat file

 

FYI, I have been able to create tools and export them to the metric file and see them in my tool_database.dat file.  But I am unable to do the same to the english file, hence the error to "export to library"

 

 

Re: export to library error

From the syslog, we see these are the folders the system is looking in: 

    UGII_CAM_LIBRARY_DIR             C:\Users\surirol\Desktop\DESKTOPlibrary\
    UGII_CAM_LIBRARY_TOOL_DIR        C:\Users\surirol\Desktop\DESKTOPlibrary\tool\
    UGII_CAM_LIBRARY_TOOL_ASCII_DIR  C:\Users\surirol\Desktop\DESKTOPlibrary\tool\ascii\
    UGII_CAM_LIBRARY_TOOL_GENIUS_DIR C:\Users\surirol\Desktop\DESKTOPlibrary\tool\genius\
    UGII_CAM_LIBRARY_TOOL_INCLASS_DIR C:\Users\surirol\Desktop\DESKTOPlibrary\tool\inclass\
    UGII_CAM_LIBRARY_TOOL_ENGLISH_DIR C:\Users\surirol\Desktop\DESKTOPlibrary\tool\english\
    UGII_CAM_LIBRARY_TOOL_METRIC_DIR C:\Users\surirol\Desktop\DESKTOPlibrary\tool\metric\

The problem is the space in the file path to your ugii_env.dat file:

UGII_CAM_RESOURCE_DIR=C:\Users\surirol\Desktop\DESKTOP JUNK\cnc training\demo\resource\

The definition stopped at the space after DESKTOP. You need to either make a file path without spaces, or enclose the path in quotes. 

 

 

Mark Rief
Retired Siemens

Learn online





Solution Information