Showing results for 
Search instead for 
Do you mean 
Reply

hole making frustrations

Am I the only one constantly struggling with hole making operations? When the holes are not oriented in the ZM axis, about 50% of the holes, NX comes up with the wrong hole orientation. It's even so absurd that a blind threaded hole may get accessed from within the part with the thread starting from the bottom going up. I can correct it by switching from blind to through hole, flip the orientation, switch back to blind. The tool path is correct, the visual high lighted thread is still wrong.
Another annoying thing is the time NX needs to identify holes once the are selected. Especially when some holes are right and some holes are oriented wrong.
This is computer independent, and happens both on customized environment as on ootb NX. These same issues happen on all versions of NX since hole making was introduced.
I'll post some screen shots the coming days to show it.
Patrick Delisse
KMWE - DutchAero
NX11.0, CAMPOST V22, Vericut 8.0
6 REPLIES

Re: hole making frustrations

Hole making operations?

Perhaps this should be in the manufacturing forum?

Re: hole making frustrations


cowski1 wrote:

Hole making operations?

Perhaps this should be in the manufacturing forum?


Correct - I moved it here.

Mark Rief
Retired Siemens

Re: hole making frustrations

Here's a screen shot of what I see a lot with hole making.

Just discovered an important thing. I was setting up a simple sample file and as always everything worked fine.

Then I added the model as master model in an assembly and repositioned the component.

Now operations start to get messed up. See attached sample file.

This is not only limited to thread, i've seen the same things on counterbore holes and simple holes.

 

 

Patrick Delisse
KMWE - DutchAero
NX11.0, CAMPOST V22, Vericut 8.0

Re: hole making frustrations

Hi Patrick,

 

You are absolutely right; almost all in-process features in your test part are incorrect. This appears to be a critical software problem.

 

We haven't figured out yet what's happening. Initial tests on our side where we created an empty CAM assembly, added the model as master model in theassembly and repositioned the component worked just fine.

 

We'll continue to try and figure this out; it's not how the software should behave.

Would you be able to create a quick AVI to show us how you created the CAM assembly?

I am hoping that this will help us get to the bottom of this.

 

Tom van 't Erve

NX CAM Development

 

Re: hole making frustrations

Hi Tom,

 

Made a movie with NX10 ootb (same problem)

Can't attache this huge movie file, so I put in in my onedrive, here's the shared link.

http://1drv.ms/1X57AFM

Patrick Delisse
KMWE - DutchAero
NX11.0, CAMPOST V22, Vericut 8.0

Re: hole making frustrations

Hi Patrick,

 

The problems with the thread being machined from the wrong side is a known issue for which a fix is submitted for NX10.0.3 MP2. It only occurs for not full thread and depends on the part placement in the assembly.

In case you have more problems with the new drilling operation please files PR's for them so we can help you solve these issues.

 

Theo Balkenende

NX CAM Development

Learn online





Solution Information