Cancel
Showing results for 
Search instead for 
Did you mean: 

nx cam NX9.0

Creator
Creator

I have problem for nx cam NX9.0 , Please help me

file attched

https://drive.google.com/drive/folders/0B5RQlOhl3inpQmpsUTMzcmtXVU0?usp=sharing

anh đưởng chạy dao .JPGảnh thực tế.JPG

10 REPLIES

Re: nx cam NX9.0

Creator
Creator

How does your machine handle G00 movements?

 

I will guess that your machine do "dogleg" rapids, it will execute a G00 move at each axis highest possible feed rate and therefore not reach its target coordinates at the same time.The result will not be a straight move.

 

In many cases you can control how the machine handle G00 rapids in the machine parameters, otherwise so will you need to rapid to a safe hight before you does execute a G00 move in X-Y axis.

Re: nx cam NX9.0

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Use Non Cutting Moves => Transfer/Rapid => Between Regions => Clearance - Tool Axis which is much safer for any machine.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.1, FBM, MRL 3.1.7 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 11.4
Development: C (ITK), .NET, Tcl/Tk Testing: NX12.0 | AWC 3.4 Preparing: NX12.0

Employees of the customers, together we are strong Smiley Wink
How to Get the Most from Your Signature in the Community
NX Customization - Best Practice Guide

Re: nx cam NX9.0

Creator
Creator

thank you very much.

Re: nx cam NX9.0

To see if doglegs are the issue, you can go to feeds in the operation, and change the rapid mode from G0 to G1 with the max feed of the the machine.

Mark Rief
Retired Siemens

Re: nx cam NX9.0

Creator
Creator

Thank you very much . I change the rapid mode from G0 to G1 with the max feed of the the machine. But post to nc file no have Z at G43. pls help me. g43.PNG

 

Re: nx cam NX9.0

Valued Contributor
Valued Contributor

change your traversal feedrate rapid to mmpm 

-----------------------------------------
NX 11.0.2.7 MP10 / Testing NX 12.0.2.9
CanikSoft NC Post-Processing & G-Code Simulation
www.plast-met.com.tr
www.caniksoft.com

Re: nx cam NX9.0

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

You may need to add a "MOM_force once Z" command AFTER the "G91 G28 Z0" line gets output.

Especially if your first move is to Z0.0

 

If there is a "MOM_force once Z" before the "G91 G28 Z0", the Z0 of that block will satisfy the "force once".  (assuming that block has a Z word in it).

So if you end up wanting to go to G54 Z0, it doesn't see the G54 Z0 as a different position in Z, so it doesn't trigger the modal output.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: nx cam NX9.0

Creator
Creator

i can do. thank you very much. 

Re: nx cam NX9.0

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

This is a known behaviour, in most cases solved by the suggestions shown earlier in this thread.

We are now working on a project for a Brother machine (NX11). On this machine there is no machine parameter that can be changed so that the G00 move is interpolating.

Using a high feed rate is not accepted by the operator. Reason is that now he has 2 control buttons, one for G0, and one for feed moves, allowing to control the speed of the machine.

During the first run, they set the G0 button to 0%. and allow the machine to execute the cutting moves.

In this configuration, the machine stops at a line with G0. Then the operator opens speed, controlled.

Retracting all moves is generating to much moves..

 

Is there a setting in the ISV CSE environment that simulates the G0 moves, with a dogleg move?

 

Best regards,

 

Camiel Rys

Learn online





Solution Information