Showing results for 
Search instead for 
Do you mean 
Reply

nx10 UGII_TMP_DIR will be used to output CAM Data

I've been dealing with this issue since nx8.5. I was hoping it would be fixed in nx10. Does anyone know a solution?

Every time I start a new CAM file and post for the first time it gives me this. I have to close and restart nx and then post to get it to save the files in the right spot.

NX11.0.1
6 REPLIES

Re: nx10 UGII_TMP_DIR will be used to output CAM Data

From the NX10 "ugii_env_ug.dat" file:

# If LIBRARY_CAM_OUTPUT is defined in the CAM configuration file, then
# this directs MOM to place output files in a specific location.
# A folder under this root with the part name is created for each CAM setup.
# If not defined, the folder is created in the current part directory.
# UGII_CAM_SETUP_ROOT_DIR=

 so...

- check LIBRARY_CAM_OUTPUT in the configuration file (mach\resource\configuration)

 

- I'm guessing you use a customized environment?

- If an "As installed" configuration file, which one?

- Did you update your configuration file(s) to NX10, or did you just copy the NX9 ones? (possibly NX10 added one or more lines to the "as installed" ones, that are not in yours?

 

Hope this helps

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: nx10 UGII_TMP_DIR will be used to output CAM Data

The problem is that you use a CAM configuration that has LIBRARY_CAM_OUTPUT defined.

 

If you don't want to have a centralized output, remove the line containing the variable in the configuration or use a different configuration.

 

You may also want to check the NX documentation topic Manufacturing General => CAM Customization => Data Management.

 

So the fix is to use the correct CAM configuration, that meets your needs.

 

Depending on the CAM configuration you use there will also be one that has just that setting not enabled.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: nx10 UGII_TMP_DIR will be used to output CAM Data

Why does it only happen on the first time the cam file is created and tried to post? If I create a CAM file, save, close nx, reopen nx , reopen file and post. I dont get this problem.
NX11.0.1

Re: nx10 UGII_TMP_DIR will be used to output CAM Data

The PAX file containing the setup template you are using also has the configuration set, so this might be different from what you use normally.

 

Make sure to also use your configuration for the File => New templates.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: nx10 UGII_TMP_DIR will be used to output CAM Data

Hi, I'm currently having this problem also. I am also working in a custom enviroment. After if initial error pops up; if I save the part and reload NX, everything continues as normal. 

 

Is there something I could add to my ugii_env.dat file to correct this? If not, what do I need to change inorder to redirect the configuration to the correct location?

 

Thanks. 

Re: nx10 UGII_TMP_DIR will be used to output CAM Data

Never mind, I was able to figure it out after reading the suggestions a little more closely. To sum up how I fixed this was to;

-First, completely exit NX.

Then, open the location of your customized pax file. The default location is
C:\Program Files\Siemens\NX 11.0\UGII\templates\ - ugs_manufacturing_templates.

You will need to used the pax file located in your custom location.

-Next open the file in a text editor. Your looking for the line that says:

<Configuration>${UGII_CAM_CONFIG_DIR}cam_library.dat</Configuration>

The easiest way is to change this too:

<Configuration>${UGII_CAM_CONFIG_DIR}cam_general.dat</Configuration>

-Then save and close. You will have to do this to each custom environment you have created.

Hope this helps.

Thanks

Learn online





Solution Information