Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

retrive tool error

Gears Phenom Gears Phenom
Gears Phenom

Machine shop has been getting this error, when they try to retrive certain tools from the library. (see image below)

 

Looking at trackpoint_database.dat, there seemed to be an extra | 0 at the end of the tracking_point lines (see second image), so I removed them, and now they no longer get the error.

 

My questions are:

Was I correct in seeing extra data segments?  I counted the line above, to compare

How would this extra bit of data gotten in there?

 

I doubt they would be editing the file manually.

 

 

tool_error.jpgtrackpoint.jpg

-Dave
NX 11 | Teamcenter 11 | Windows 10
2 REPLIES

Re: retrive tool error

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

The number of columns in the DATA lines *should* match the number of items in the FORMAT lines (somewhat spaced out to make it clearer):

#CLASS MILLING_DRILLING
FORMAT LIBRF          T  STYPE NAME      SEQ ADJREG ADJSTAT CUTREG CUTSTAT DIAM DIST      ZOFF    ZOFFSTAT DEFTYPE
#------------------------------------------------------------------------------------------
DATA | TPI001_00001 | 1 | 0  | PILOT_DIA | 2 | 0 |   0 |     0 |     0 |  0.250 | 0.00  |   0.00000 | 0 |    0

I have no idea why the extra data.  Other than manual data entry or cut/paste error...

*best stab in the dark* 

Different versions of NX - possibly an MR (?MP?) sarted adding the extra data?

Check all users are on EXACTLY the same version of NX

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: retrive tool error

Gears Phenom Gears Phenom
Gears Phenom

Good thought on the version, I'll need to check that. 

 

Also possible that one of the Siemens reps we had helping them out did an incorrect copy-paste, but that was a while ago.

-Dave
NX 11 | Teamcenter 11 | Windows 10

Learn online





Solution Information