Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

smooth transfer not working with stepover on part (contour area)?

Using contour area with scallop stepover on part. The option for smoothing in non cutting moves is there but doesn't do anything. However with stepover applied on plane it does work. I'm I missing something?

 

(Pic with stepover on plane and desired smoothing)

 

(NX 10.0.3.5 MP3)

 

Harri

13 REPLIES

Re: smooth transfer not working with stepover on part (contour area)?

Could you also post an image of the situation where it doesn't work?

A sample part file with two operations for each situation would also help to be able to check if there is a setting that prevents the tool path from being as expected.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: smooth transfer not working with stepover on part (contour area)?

Thanks Stefan,

 

here is a picture with stepover changed to "on part". Engages and retracts smooth out but transfers within regions don't. I'm unfortunately not allowed to post the actual file but we worked on this with local support and couldn't get smooth transitions unless stepover was applied on plane.

 

Thanks/Harri

Re: smooth transfer not working with stepover on part (contour area)?

This might have something to do with my problem; I can only get smoothing to work if Cutting parameters->corners->Smoothing is set to all corners. However this prohibits stepover on part. Is there a way to smooth the transitions without using this setting? 

 

 

Re: smooth transfer not working with stepover on part (contour area)?

Sample files attached

Re: smooth transfer not working with stepover on part (contour area)?

When NX tells you that a combination of settings doesn't work together, then there is nothing you can do about it.

In such a case you should file an enhancement request at GTAC and post the ER number here, so other members could request being added to the ER, if they also like to have that feature.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: smooth transfer not working with stepover on part (contour area)?

Stefan, I feared this might be the case.

 

Just checking: does smoothing in non cutting moves require smooth corners to be activated in cutting parameters? If this is the case, there's nothing to be done. If not, I still might have a problem with one of my other settings.

 

Anyway, thanks for looking!

 

Harri

Re: smooth transfer not working with stepover on part (contour area)?

Smoothing the corners is mostly used only for patterns that do not lift at the corners, so smoothing the traverse move and using zig-zack with lifts would not require corner smoothing.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community
Solution
Solution
Accepted by topic author hjoy
‎07-14-2016 02:52 AM

Re: smooth transfer not working with stepover on part (contour area)?

[ Edited ]

In the picture, the green moves are stepovers, which are part of the cut pattern, and not transfer moves. The smoothing of these is controlled by Cutting Parameters > Corners. You can not use this corner smoothing with on part stepover in area milling. 

If you change the cut pattern to zig-zag with lifts, the green moves will be nice and smooth, because they are now part of the non-cutting moves, and controlled by Non-Cutting Moves > Smoothing. 

Zig Zag vs. Zig Zag with LiftsZig Zag vs. Zig Zag with Lifts

Mark Rief
Retired Siemens

Re: smooth transfer not working with stepover on part (contour area)?

[ Edited ]

Thank you Mark, excellent solution!

 

If I were to nitpick, what's up with the slip in the picture? And is there a way to keep the stepovers on the (imaginary/extended) surface? I ask mostly out of interest, not trying to say there's anything wrong with the current stepover smoothing..

 


smoother.jpg

Thanks/Harri

 

Learn online





Solution Information