Cancel
Showing results for 
Search instead for 
Did you mean: 

unable to select the workpart for manufacturing

Creator
Creator

I am not able to select the workpart that is to be machined and I couldnt assign it a bounding block. I have imported my part from SOLIDWORKS , but I am able to select a part that has been modelled in siemens. I am using NX9 , so please help me sort this out.

8 REPLIES

Re: unable to select the workpart for manufacturing

Genius
Genius

Without a file it's hard to say, but is it possible that the part is in fact not a solid? Your selection filters are set to entire assy and solid, which would prevent selecting face-only bodies.

ct.JPG

 

Harri

Re: unable to select the workpart for manufacturing

Creator
Creator

To what should I change those to?

Re: unable to select the workpart for manufacturing

Genius
Genius

Try sheet body.

 

 

Re: unable to select the workpart for manufacturing

Siemens Legend Siemens Legend
Siemens Legend

For any customers who use non-native imported geometry for CAM programming, I always recommend using the Optimize Face command for cleaning the geometry up. This usually takes care of most geometry related problems.

 

If you want to keep the original geometry unchanged, then create a copy of it using WAVE Geometry Linker or Extract Geometry. Then use the Optimize Face command on the copied part.

 

Use the default settings in Optimize Face. They are usually good enough to clean your part. Try this and see if you can select the body in workpiece afterward.

Re: unable to select the workpart for manufacturing

Creator
Creator

I  found it out. It was solved after I saved my SOLIDWORKS model from igs format to STEP format. thank you guys for your ideas.

Re: unable to select the workpart for manufacturing

Genius
Genius

@sadak12,

 

igs is surfaces only. As you mentioned, you can save as stp, and you will have a solid if there is a solid in the file. You can use the igs too, just make sure the appropriate selection filters are used. Glad to hear you sorted out the problem.

 

Harri

Re: unable to select the workpart for manufacturing

Siemens Legend Siemens Legend
Siemens Legend

You do have the ability to get a Solidworks part directly into NX without having to export a Step or IGES file. There is no Solidworks option when you use File-->Import, but if you simply use File-->Open you can change the Files of Type to a .sldprt file extension and open the Solidworks part for a direct translation.

 

open.JPG

Re: unable to select the workpart for manufacturing

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Note that opening solidworks files directly is not an option included in all the bundles. You may need to buy an additional license to access this functionality.

Learn online





Solution Information