cancel
Showing results for 
Search instead for 
Did you mean: 

Database modification

Creator
Creator

Hello all

 

I added a new material to my MaterialDB following the instruction in one of the posts, but when I want to add it, it just displays 3 rows of materials, the new material doesn't even show up. Can someone help me out? 

 

DB_Fibersim.JPG

 

matl_db.JPG

 

Thank you and very much appretiated. 

 

 

9 REPLIES

Re: Database modification

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Hi Emma,

 

From your screenshots, it looks like you're using Microsoft Excel to edit your MaterialsDB.xml file. Is that correct? I can't say whether that's possible or not as I've never tried it before, but I would STRONGLY recommend just using a simple text editor like Notepad or Wordpad.

 

Using a text editor is easy, as each material entry is clearly tagged in the file. The quickest way to add a new material is to select an entire existing entry (all the way from the opening "<Material>" tag to the closing "</Material>" tag), and simply copy and paste it anywhere among your existing materials (but between the file's main <Application...> tags). Once you've duplicated the entry, you'll then of course have to change the parameters' values. For example, at the very least, you'll need to change <Specification> to the actual name of your new material.

 

The main advantage in using a text editor in this manner to modify your MaterialsDB.xml file is that it will allow you to save your changes without altering the format of the file (which is likely the problem you're currently seeing). Of course, if this doesn't resolve your issue, you can always drop us a line. You can reach the Fibersim GTAC team by calling 1-800-955-0000, press 2 for technical support, enter your Sold-To ID and hit #, and finally press 7 then 1 for Specialized Engineering Software. Alternatively, you can log an issue online and send us a copy of your MaterialsDB.xml file in one step by logging onto the GTAC website using your WebKey account:

https://webtac.industrysoftware.automation.siemens.com/qtac/index.php5?lang=en

 

Thank you very much.

Re: Database modification

Creator
Creator

 Hello Sanjeev

 

Thank you so much for your valuable information. I just opened the MaterialDB xml file with notepad just to check it out, and surprisingly all the materials are in there, including the one I just crated; BUT, I still can't see or add it in fibersim:

 

matldb.png

 

And it is still displaying only 3 materials:

 

Material DB after opening and closing Fibersim after reviewing the XML file in notepad.Material DB after opening and closing Fibersim after reviewing the XML file in notepad.

I'll log in the issue online.

 

Once again, thank you so much!! Smiley Happy 

Re: Database modification

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Hi. The reason it is not showing up in Fibersim may be caused by the fact that you do not have an Areal Weight assigned to you new material. While Fibersim doesn't need every specification in the world for a material, I think it at least needs the areal weight (as you can see your other materials contain). Just try copying the areal weight from one of your other materials. 

 

That being said, it looks like your existing materials have been "thinned down" quite a bit from one of the default materials. You are going to lose a few options (like the different highlighting colors for different material orientations). I would go back to the original material database, copy over the entire section for a material such as PPG-PL3K, and then put in your own information.

 

Finally, you do not need to restart your cad session every time you make a material change. Once you have saved the .xml file, go back into Fibersim and click Tools, then choose "Syncronize Database Now".

 

Hope this helps!

Re: Database modification

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Ah, I believe Crafty is correct: some material parameters (such as the ones controlling highlighting color) are not vital in Fibersim, but many of them are required for proper functioning of the software. In my first message, I'd mentioned that at the very least, you'd need <Specification> set to the actual name of your material. "Specification" is definitely one of the required ones, as Fibersim uses it as the material's unique identifier. In other words, you could copy a material precisely in your database, and change *just* the Specification to make it unique, and it would work fine. On the other hand, if you had two materials in your database with the same Specification, the software would likely behave unpredictably...even if ALL of the other parameters had unique values.

 

As Crafty said, I would find a sample material in the database that's similar to what you're actually working with, copy the ENTIRE entry, and change just the parameters you're sure about (leaving the rest set to the sample material's values). For example, if you're working with a woven prepreg, then copy the entire "PPG-PL-3K" entry to get your new material's template. If you're working with a unidirectional tape, copy the entire "T-6-in" entry. If you're working with a triax NCF, copy "NCF-3_layer". And so on...

Re: Database modification

Creator
Creator

Hi team!

 

Thank you for your support. I copied and modified the parameters as suggested, synchronized the databases in Fibersim, but I stil get only 2 prepreg materials and a foam core (which come as default). I checked the DBConfiguration file and it seems ok. Maybe I'm missing somethig?

 

Regards!

Re: Database modification

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Sorry to hear about the continuing difficulties you're experiencing with the database, Emma. If you could post another screenshot of what the new material entries look like in Notepad like you did before, maybe we can try and spot any errors. If everything looks good, then it may, in fact, be some sort of issue with the DBConfiguration.xml file, as you mentioned...

 

Thank you very much.

Re: Database modification

Creator
Creator

Hello!

 

Of course, here you go:

 

matldb0.png

 

And this is the DBConfiguration screenshot.

 

Pt 1Pt 1Pt 2Pt 2

(I don't know if it's helpful, but we use Creo Parametric 3.0 for CAD).

 

Regards and thank you so much!

Re: Database modification

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Emma, did you happen to see my post from later in the day on Friday? I'm sorry if I wasn't clear, but just to reiterate, you MUST have the <Specification> parameter in each of your new materials. Fibersim uses that parameter as the unique identifier for each material. Your latest screenshot of the database open in Notepad still shows no Specifications for any of your materials. As such, Fibersim won't recognize those materials. Please try adding the Specification back in and see if that resolves the problem. Thank you very much.

Re: Database modification

Creator
Creator

Hi!


Oh no, don't be, it was my mistake for not double checking. I just updated the lines and it worked!!


Thank you so, so much!! Smiley Happy

 

Regards.