Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: SSH connect to PostgreSQL service instance

Legend
Legend
@yuhe It's mandatory to bind your service db to an application, you won't be able to reach it otherwise. In your sample you are trying to ssh and then create a tunnel port, are you even able to ssh directly to the sqltool app? The error you get points to the answer being no.

Re: SSH connect to PostgreSQL service instance

Siemens Creator Siemens Creator
Siemens Creator

@HoangDQ,I enabled the ssh service for my binded mindapp, but still can't complete the ssh tunnel configuration. I would like upload some screenshots, pls kindly check.

Step1. had bound the db instance with my mindapp

Step2. had enabled the ssh for mindapp

Step3. get the external access key of the db instance

Step4. ssh tunnel configuration

Re: SSH connect to PostgreSQL service instance

Experimenter
Experimenter

Hi

I have enabled ssh for app and space, still coudnt configure ssh to access postgres instance locally, cf CLI got struck when i give a command cf -L 5432:host:5432 appname.

 

attached screenshot ,pls help on the same

Re: SSH connect to PostgreSQL service instance

Legend
Legend
I suggest you run your command with the '-v' flag; the verbose output will show you where the issue is.