Cancel
Showing results for 
Search instead for 
Did you mean: 

Connect TIA Portal to Process Simulate

Pioneer
Pioneer

Hi everyone,

 

I need to connect TIA Portal to my CAD project in Process Simulate. Can anyone help me with setting up this connection or refer me to a tutorial or anything like that?

8 REPLIES

Re: Connect TIA Portal to Process Simulate

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

To do this, you need PLCSIM Advanced (PSA).

The rest is very simple. In PSA create a virtual controller instance, load your Tia project into the virual controller.

Afterwards, create a External conntection in PS.

 

To do this, you minimum need PS13.1.1 or newer and TIA v14.

PSA 2.0 is currently not supported.

 

Best regards

Patrick

Re: Connect TIA Portal to Process Simulate

Pioneer
Pioneer

Thanks for the reply, so this doesn't work with TIA v13?

Re: Connect TIA Portal to Process Simulate

Siemens Phenom Siemens Phenom
Siemens Phenom

No. You need TIA v14 or newer.

 

Best regards

Patrick

Re: Connect TIA Portal to Process Simulate

Pioneer
Pioneer

Are there any options to do something similar for v13? I don't currently have access to version 14...

Re: Connect TIA Portal to Process Simulate

Siemens Phenom Siemens Phenom
Siemens Phenom

You can use a the "hardware in the loop" solution, but then you need to have a PLC and a "SIMIT Unit/Simulation Unit".

This is what we want to prevent by using PLCSIM Advanced which is a "software in the loop" solution. No more Hardware required.

 

Best regards

Patrick 

Re: Connect TIA Portal to Process Simulate

Pioneer
Pioneer

What is the reason PSA 2.0 is not supported? I checked the function manual of PSA and found that PSA v1.0 en v2.0 are both compatible with TIA v14 and v15. Is there a problem between PSA v2.0 and PS?

Function Manual table 2- 3 on page 35.

Re: Connect TIA Portal to Process Simulate

Siemens Phenom Siemens Phenom
Siemens Phenom

Not TIA Portal is the problem. 

I would say it´s not compatible with PS14.0 because PSA2.0 was released after PS14.0.

I´m not sure if PS14.0.1 is compatible with PSA2.0. I would say "no".

 

Best regards

Patrick

Re: Connect TIA Portal to Process Simulate

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

Update:

PlcSim Advanced 2.0 works with the current PS versions.

 

Best regards

Patrick