Cancel
Showing results for 
Search instead for 
Did you mean: 

process simulate - welding operation

Creator
Creator

hi everyone, 

i am doing project in tecnomatix process simulate. i did some welding operation and pick and place operation in standard mode. but after i changing to line simulation mode, the welding process seams to be not working. but it works fine at standard mode.  anyone help me out from this problem.

 

5 REPLIES

Re: process simulate - welding operation

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

LineSimulation mode works different to Standard mode. What you are showing in your picture is not clear to me, because it shows the MFGs and not your weld OP.

 

The MFGs are assigned to a part. No in Line Simulation its imporant where your Part/Appearance is generated.

If it is not in the same position generated as it was located in Standard mode your weld locations are not at the same position.

For Line Simulation mode it is important that all your location are taugth and a config. In this way for the robot it is still possible to perform the movement of the operation also when Mfgs and Weld locations are not at the correct position.

 

Using Line Simulation mode is a completely different workflow.

 

Best regards

Patrick

Re: process simulate - welding operation

Creator
Creator
Sir
i got you what you said but the problem is we have three parts of chassis. where the first two parts flows in conveyor separately and pick and place operation takes place and the welding operation and it repeats for third part..the thing is after welding the two parts remain separate. we have given object flow for those two separately at another conveyor matching the location. we have done all these in standard mode. when we change it to line simulation mode we have given appearances at start from object flow operation it shows extra two parts moves in conveyor but actual ones remain at start position..if we give appearances at welding operation then it works but we need appearances from the start. and we want appearances throughout complete process without extra parts and continuous welding operation.
we are stuck due to this please help me out with this problem.

Thanks&Regards
Santhosh

Re: process simulate - welding operation

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

If you have an assembly you should work with with a hierarchy e.g.

 

CarAssembly (CompoundPart)

     - Front (CompoundPart)
            - Part1 (Part)
            - Part2 (Part)

     - Back (CompoundPart)

            - Part3 (Part)

     .....

 

When you want to build e.g. "Front" in your station you have your seperate flows for "Part1" and "Part2".

After welding, the two single appearances should be destroyed and afterwards you should work with compound part "Front". This will include the two parts as an subassembly of the "CarAssembly".

 

All this can be controlled by MaterialFlow Viewer. 

Here you need to add the operations and connect them to get a material flow.

 

Best regards

Patrick

 

Re: process simulate - welding operation

Creator
Creator

sir i did simulation like above what ever you said. i created compound part and added parts in compound part. but while simulation parts are moving some where. I will attach the video of my simulation below. please help me out.

Re: process simulate - welding operation

Creator
Creator

(view in My Videos)
ff.JPG