Cancel
Showing results for 
Search instead for 
Did you mean: 

"New Device Operation" start signal or trigger it run in CEE mode

Valued Contributor
Valued Contributor

Hi  all

 

I am facing problem to trigger a turn table run in Line simuation in CEE mode, I create "New Device Operation" for turn table and put two pose in it, but in Line simulation mode, it will be continue run and not stop, I would like to add one signal to trigger it start when I want it run  like "Robot start signal".

 

how to make it come true?

 

I heard the op start signal will not working in CEE mode and only for PLC mode

 

Thanks 3.PNG4.PNG

3 REPLIES

Re: "New Device Operation" start signal or trigger it run in CEE mode

Valued Contributor
Valued Contributor

seems it is working out when I creat a new "No sim Op" and link it with Device Operation and put the "Transition" with Device Op start signal. is it correct process ?

 

or do we have another method to make it come true?

 

Thanks

Re: "New Device Operation" start signal or trigger it run in CEE mode

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

For your Device operation, you need to create the "Device Start Signal". Select the operation and click on "Create Devie Start Signal". This will create a signal in Signal Viewer "yourDeviceOperation_Start".

 

In Sequence Editor, you need to put a Non-Sim Operation as top node of all your operation.

The Non-Sim Operation is used to prevent all operations to become executed after starting the simulation.

Connect all operation below to the Non-Sim (one by one)

In transitions of Non-Sim change to "Alternative" and add the "yourDeviceOperation_Start" as transition.

Afterwards, it should look like this:

linesim.jpg

 

Good luck.

 

 

 

Re: "New Device Operation" start signal or trigger it run in CEE mode

Valued Contributor
Valued Contributor

Hi

 

Thanks , it is come ture the same follow your direction

 

Thanks