Cancel
Showing results for 
Search instead for 
Did you mean: 

JT2Go 11.3.0 on Win10, no model visible

Experimenter
Experimenter

Hello,

I'm using JT2Go 11.3.0 on Windows 10 (Lenovo E470) and when i open a jt file I can't see any model. But on the left are the different elements for this specific model listed. In Addition the file is working fine at collegues system (same Hard- and Software).

 

So far I checked new Updates and Drivers, and the only difference is that i had installed VLC-Player previously. I reinstalled and restarted my system a few times already. But there is only a white screen with Siemens visible. If i rightclick on different areas and select "View only" different elements in the left list are ticked.

 

Best Regards

cado

 

 EDIT:

I'm using the ThinkPad Pro USB Dock connected to two monitors on these the render screen is not updated, but on the original laptop screen it works fine. Updated drivers for monitors and usb dock but no change. Any Suggestions?

10 REPLIES

Re: JT2Go 11.3.0 on Win10, no model visible

Siemens Legend Siemens Legend
Siemens Legend

So if I read this right (just making sure).  If you are using just the ThinkPad itself, everything renders correctly.  It is only when you dock the ThinkPad that the app does not appear to be rendering correctly on the connected monitors, correct?

 

I am having a hard time trying to picture what this looks like.   Is there any chance you can take a snapshot of the screen where it isn't working?

 

Thanks,

Rick

Re: JT2Go 11.3.0 on Win10, no model visible

Experimenter
Experimenter

Hey Rick,

 

yeah exactly the rendering window is frozen as long as the whole window is not on the laptop screen. Just moving it there is enough to let it work again. By rendering screen i mean the red marked area in the attached screenshot.

 

Thank you,

cado

 

screen.png

Re: JT2Go 11.3.0 on Win10, no model visible

Gears Legend Gears Legend
Gears Legend

Hello,

this is an well-known problem.

Try to find out your configuration when the Laptop is not at the docking station and when he is at the docking station.

Same procedure is also to use if you plug in a beamer or other output devises.

Have uploaded some examples how to find out the configuration.

A laptop switch between docking, plugin and standalone use the graphic card some times between on-board and other GPU. This you can find out if you take a look at the configurations when the laptop is in standalone and in plugin mode. This is to change in the GPU use. This is different between Intel on-board, Nvidia and AMD. You must set the visview.exe in JT2Go on high performance for every use of the Laptop. This will help. If not change also the openGL settings lower. Most is in use around 4.... try it with 3... and restart JT2go after change.

Here is the way in JT2Go how to find the config. For GPU change please use the help from your GPU card or let me know your GPU.

Hop this helps you a bit.

 

Best regards Wolfgangstep_02.jpgstep_01.jpg

Re: JT2Go 11.3.0 on Win10, no model visible

Siemens Legend Siemens Legend
Siemens Legend

Wolfgang - thanks for the analysis.  I've only ever run into issues when using Remote Desktop, which will put JT2Go into Software rendering mode and causes similiar issues and requires a reboot of the machine to fix.  I'll keep the info you have posted handy, in the event someone else runs into it.

 

Rick

Re: JT2Go 11.3.0 on Win10, no model visible

Experimenter
Experimenter

I have the same problem on a Z640 workstation and a nVIDIA GTX 1080 FE, Win10 64bit build 1607.
The problem happend since Geforce driver version 385.41

If I revert to version 385.28 no display issue.

If I go to the troubleshoot area, OpenGL 1.1 is forced and recommanded. If I change to OpenGL 4.5, no more trouble.

Hope this will help.

 

 

Re: JT2Go 11.3.0 on Win10, no model visible

Gears Legend Gears Legend
Gears Legend
Yes, have hade the same truble. Seams the new driver of NVIDA and JT2Go 11.3 does not macht direct. You must find the best settings now selve.

Re: JT2Go 11.3.0 on Win10, no model visible

Experimenter
Experimenter

Hi Wolfgang_1, you seem to be a chap that knows his stuff, so perhaps you can answer a question I have related to OpenGL GFX setting in JT2Go 11.3?

 

The Troubleshooting Performance screenshot that you show in your post, where you chose the OpenGL version compatibility - where is this value stored local on the machine/registry? I have searched everywhere so that I can set this manually rather than in the UI, but can find it no where.

 

The reason being is that I build the Master image for all my machines on a VM with no OpenGL so it defaults to the lowest setting, but that when this image is deployed to my phsical cad machines, the will not work unless the user manually increases this value to the highest value. I would hence like to change the setting on the Master VM via the config file / registry fix as I cannot do it via the UI so that it is correct when deployed to my users.

 

Would be great if you have a solution to this?

 

Rgds

 

Gary

Re: JT2Go 11.3.0 on Win10, no model visible

Siemens Legend Siemens Legend
Siemens Legend

The value in the registry is a dword value that represents the OpenGL version you would like to see.  For instance 4.3.0 is the value below (430 decimal).  1.1 equates to 0000006e (110 decimal).  4.4.0 woud be 000001b8 (440 decimal)

 

[HKEY_CURRENT_USER\Software\Siemens\JT2Go\11.3\JT2Go\C\Vis3D]
"Default OpenGL Version"=dword:000001ae

 

If you have the latest released version (11.4, the version in the registry key above would obviously have to change to 11.4).

 

Rick

Re: JT2Go 11.3.0 on Win10, no model visible

Experimenter
Experimenter
You are a Star !!

Thanks very much.