Cancel
Showing results for 
Search instead for 
Did you mean: 

Jt2go Doesn't loading B-rep Data Correctly.

Experimenter
Experimenter

JT File Issue with B-rep

  • JT File with B-rep Data
  • image.pngthe file contains b-rep data when opened in Jt2go circular surfaces are not smoothimage.pngSame file when opened in Creo View, circular surfaces are smooth for B-rep Dataimage.pngFile has no difference when compared with file having b-rep data while viewing in Jt2go.image.pngCreo View image of only facet Data file differs from the file having b-rep data.

 

 

Conclusion: - As Including B-rep Data doesn’t reflecting any change in Jt2go we want to check that

1)Does Jt2go expect B-rep data in another format then how we are writing currently in attached JT, Please Explain?

2)OR Jt2go has some issue while processing B-rep Data?

3)OR Is there any setting required in Jt2go for processing B-rep Data.

 

  • Also, To add more information, we have done further analysis and below result

Application that read JT correctly:

  • Creo View
  • AutoDesk Viewer
  • Keyshot

Application that do not read JT correctly:

  • IDO
  • JT2Go
  • Teamcenter VisView, VisMockup
  • Autodesk VRED

 

Please let us know your observation on the same.

 

9 REPLIES 9

Re: Jt2go Doesn't loading B-rep Data Correctly.

Experimenter
Experimenter

Any Response for above Issue which I have submitted.

Any settings which are being missed?

Re: Jt2go Doesn't loading B-rep Data Correctly.

Siemens Phenom Siemens Phenom
Siemens Phenom

Thanks for refreshing this - somehow I missed it.

 

I'll forward the JT file to the Teamcenter Visualization team for evaluation.

 

Rick

Re: Jt2go Doesn't loading B-rep Data Correctly.

Siemens Phenom Siemens Phenom
Siemens Phenom

I actually went back and found I had sent this onto the Teamcenter Visualization team.  I had gotten one response, but was waiting for potentially more info.

 

In general TcVis will display the Tessellation authored into the JT file. This is because re-tessellating from the BRep is an expensive operation. It doesn’t cost much on a single simple part like this, but we might be loading hundreds or thousands of parts.

 

In TcVis Mockup, the user could use Part Edit to re-tessellate the model to create a smoother tessellation.  (Note, this is not available in JT2Go)

 

cid:image001.png@01D51D15.75AF7750

 

Not sure why the authored tessellation is not pickable. When it was retessellated, the part could be picked, which then allowed Measurement to work.

 

However, there is something a little strange about the BRep in this model too. Retessellating it works on one side, but the other side looks like it flips inside out.

 

cid:image002.png@01D51D15.75AF7750

 

Rick

Re: Jt2go Doesn't loading B-rep Data Correctly.

Experimenter
Experimenter

Thanks for your Reply!!

We can't view the attcahed images.

 

The basic issue is not about Re-tessellating JT file,But Jt2Go is not loading B-rep data correctly.

We have provided you the files which contain B-rep Data and which is loaded correctly in few tools which are mentioned.So we would like to know 

1)Does Jt2go expect B-rep data in another format then how we are writing currently in attached JT, Please Explain?

2)OR Jt2go has some issue while processing B-rep Data?

3)OR Is there any setting required in Jt2go for processing B-rep Data.

 

If you can share your view or Finding on above mentioned Isuues/Questions,It will helpul.

Also,Share if you have any more information about this issue from TC-Visulaization team.

 

Thanks,

Ashish

Re: Jt2go Doesn't loading B-rep Data Correctly.

Siemens Phenom Siemens Phenom
Siemens Phenom

Yes, for some reason I couldn't get the images uploaded yesterday - here they are again.

 

 

one.pngRe-tessallatedtwo.pngThe other side of it...

 

 

 

I'll forward all of your questions onto the TcVis DirectModel team, as they are the ones with the domain knowledge to answer your questions.  JT2Go is just a very slimmed down version of TcVis.

 

You cannot retessallate the data in JT2Go - that feature is a paid for licensed feature of Teamcenter Visualization.

 

Rick

Re: Jt2go Doesn't loading B-rep Data Correctly.

Experimenter
Experimenter

Hi Rick,

 

Do you heard back from the team on questions I had asked earlier ?

Please let us know your comments once you have some information on above questions.

 

Thanks,

Ashish

Re: Jt2go Doesn't loading B-rep Data Correctly.

Siemens Phenom Siemens Phenom
Siemens Phenom

Ashish,

 

No word yet.  I will let you know once I hear something.

 

Rick

Re: Jt2go Doesn't loading B-rep Data Correctly.

Experimenter
Experimenter

HI Rick,

 

Any update on questions I asked ?

 

Thanks,

Ashish

Highlighted

Re: Jt2go Doesn't loading B-rep Data Correctly.

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Ashish,

 

Sorry for the delay.  Here is the information I got:

 

If they want to improve the tessellation stored in the JT file, they could look at decreasing the chordal and segment angle properties used to tessellate the Brep into facets in the original tool that authored the JT files. I think that would give them a smoother tessellation compared to the original. They might look at if the settings in the original tool are using a relative or absolute value for these properties (e.g. smaller parts might need a smaller absolute value to tessellate smoothly).

 

This is about only thing that they are aware of that would improve the display of these parts. 

 

The re-tessellation that the core vis team did, which gave the ugly other side of the part, may be a bug in the JTBrep tessellator that they are using, so it was not an issue with the part itself.

 

There aren’t any settings to turn on that would automatically re-tessellate the model to make it look nicer. Creo View seems to be ignoring the tessellation stored in the JT file and generating a new one from the BRep. This would be a performance-expensive operation in a visualization tool where we might have thousands of parts.

 

Rick