Cancel
Showing results for 
Search instead for 
Did you mean: 

PMI Filter Configuration

Siemens Phenom Siemens Phenom
Siemens Phenom

Just started using JT2GO (11.2.3).

I have exported a model as JT from NX 10.

 

jt nx export.PNGNX JT Export

When JT is opened in JT2GO there is no PMI displayed in the UI though 'Has PMI' column in assembly navigator shows the green check mark.

If I right click by hovering the cursor over the model in UI and click 'Show PMI', it does not show any PMI. Under Menu > PMI > Filter Configuration.., I just toggle between 'Display all PMI entities' and 'Filter PMI entities by type' and click OK then PMI gets displayed in the UI. Is this expected behaviour in JT2GO or am I missing any settings that should be needed before opening a JT file?

 

jt nx export1.pngJT2GO ViewWhen same JT file is opned in 'XpressReview', PMI gets displayed correctly.

jt nx export2.PNGXpressReview viewAlso, whenever I open any JT file, JT2GO window minimizes automatically. It can be seen in the video included in the attachment along with JT file.

 

11 REPLIES

Re: PMI Filter Configuration

Genius
Genius

Hi Ganesh,

Open JT file and set PMI Preferences as shown in the image,

Manufacturing>PMI Preferences

pmi.png

 

 

 

 

RRG

Re: PMI Filter Configuration

Siemens Legend Siemens Legend
Siemens Legend

Jt2Go and XpresReview are two different products and you can't compare their behaviors.

 

Jt2Go acts just like Teamcenter Visualization.  If you want to see the PMI, you must go to the Manufacturing tab in the ribbon and select the type of mode (toggle single or toggle multiple) and then select the part in the viewer and you should see PMI displayed in the viewer and the PMI tree filled in with PMI and Model Views.  In the case of the data you sent, the toggle single mode shows no PMI data.  Toggle Multiple does.   I am not a PMI expert, so I cannot tell you what is the logic behind showing you the data or not.  You can also expand the PMI Tree to see the individual dimensions that are on the part and turn them on/off.

 

Rick

Re: PMI Filter Configuration

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Rick,

 

I have checked the JT file in XpressReview just to ensure that there is no problem in PMI export.

 


If you want to see the PMI, you must go to the Manufacturing tab in the ribbon and select the type of mode (toggle single or toggle multiple) and then select the part in the viewer and you should see PMI displayed in the viewer and the PMI tree filled in with PMI and Model Views.  

It works as you described. One question on the same. Before selecting the type of mode, there is nothing in the PMI navigator (PMI,Model Views). Selecting 'Toggle Multiple' and part in the viewer shows PMI. So if 'Toggle Multple' or 'Toggle Single' option is not selected, PMI navigator will not show PMI, Model Views. Is this designed behaviour in JT2GO?

 

1.PNG

 

2.PNG

 

When JT is opened initially there were no PMI but the toggling between options 'Display all PMI entities' and 'Filter PMI entities by type' shows the PMI without selecting any other options/settings. @RickV, can you comment on this?

 

@RakeshGarud: Thank you for the suggestion! It does work only if I close and reopen the JT again.

 

About my second query,  JT2GO window minimizes automatically. It was happening at that time. Not sure what was the problem, now works fine.

 

 

Re: PMI Filter Configuration

Siemens Legend Siemens Legend
Siemens Legend

The behavior in JT2Go is as designed.  As I said, it works the same as Teamcenter Visualization, which Jt2Go is based on, so it uses the same behavior.   As far as the Filtering dialog, you are telling the viewer to show all PMI, so it shows it all, or you are showing PMI by filters, so it shows what PMI meets the filter criteria.

Re: PMI Filter Configuration

Siemens Phenom Siemens Phenom
Siemens Phenom

Thank you Rick for the response!

As I have already started using the JT2GO, I would like to continue the same and encourage its use for the users who do not have access to the CAD software. It helps to understand the complex model and to avoid the ambiguity. Personally, I had given the support to the operators on the production floor whenever they are unable to visualize the geometry of complex model from the drawing. Smiley Happy

 

Re: PMI Filter Configuration

Siemens Genius Siemens Genius
Siemens Genius

 

Hi,

Your missing a really important option, select the Model View icon in Project Workspace, this will give you a list of the model views in the part. Just select from here to see PMI

Noname.gif

 

Mike Z

Re: PMI Filter Configuration

Experimenter
Experimenter

I take the bsurfWithPMI.jt example generated using the JTToolKit  and whichever way I try I cannot get the "note" displayed. Attached the sample generated but extension changed to .txt as the JT forum does not allow .jt files to be attached (amazing?)siemens_jt2go.png

Re: PMI Filter Configuration

Siemens Phenom Siemens Phenom
Siemens Phenom

@gmorris wrote:

I take the bsurfWithPMI.jt example generated using the JTToolKit  and whichever way I try I cannot get the "note" displayed. Attached the sample generated but extension changed to .txt as the JT forum does not allow .jt files to be attached (amazing?)


Use 7Zip tool to zip files and attach here. Editing the file name extension can corrupt the file data.

 

About JT file you have provided, there is something wrong with it. I opened it in NX and it shows the warning as shown but there is note present in the JT file which can be located.

 

jtnote.PNG

  

jtnote1.PNG

 

Checked in JT2GO (11.2.3), it shows PMI note in the navigator but I am not able to read/locate it correctly.

Just changed the few apperance properties for the note. It is visible in UI like a tiny object. Unable to view it clearly by zoom operation.jtnote.PNG

 

@MikeCarter could help to know the exact issue with the JT file. Meanwhile could you please provide the JT file again without changing the file extension.

 

Re: PMI Filter Configuration

Experimenter
Experimenter

Attach as ZIP file the JT file. You can find the source that generates the file in the JTOpenToolKit