Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

I have problem with G94 (MMPM) and G95 (MMPR)

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Hi,

I create 4 axis PP and I have problem with G94/G95.
When I generate g code I have allways G94. I change in NX feed rates to mmpr, but It´s doesn´t works.
I also put in post builder in the UDE Feedrates cycle Auto, but still doesn´t work.

Capture.JPG

 

What I need to do in PP?

P.S. I attach my PP.

1 REPLY

Re: I have problem with G94 (MMPM) and G95 (MMPR)

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

The cycle feedrate setting only applies to the cycles themselves (G81, G84, or whatever)

If you program the cycle operation feedrates in NX using MMPM, the posted code will be MMPM.  If the NX operation feedrates are MMPR, posted code will be MMPR.  But for CYCLES ONLY.

 

I've never tried dealing with regular (milling/turning) operations.  Note there is the "Set Modes" which allows setting this.  If you hunt down the handler for this, perhaps you could write your own code to get what you want.

 

But I would guess there is an easier solution.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Highlighted

I have problem with G94 (MMPM) and G95 (MMPR)

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Hi,

I create 4 axis PP and I have problem with G94/G95.
When I generate g code I have allways G94. I change in NX feed rates to mmpr, but It´s doesn´t works.
I also put in post builder in the UDE Feedrates cycle Auto, but still doesn´t work.

Capture.JPG

 

What I need to do in PP?

P.S. I attach my PP.

NX CAM Postprocessor Group
NX CAM Postprocessor Group

Members (122)