Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

PostConfigurator Coolant problem

Valued Contributor
Valued Contributor

Hi,

 

I've experienced strange behaviour with coolant code output.

 

Steps to reproduce problem:

  • Create a Siemens 840D post from scratch
  • Select "Coolant Status" as On
  • Create 2 tools
  • First op: Cavity mill, Follow part cut pattern, First tool
  • Second op: Cavity mill, Profile cut pattern, Second tool
  • Post process

Now you will see that there is no M8 output at the beginning of second operation.

 

If you change cut pattern to follow part in second operation, you get M8 output. (Depends on cut pattern, what?)

 

If you change second operation to Z Level Corner, same problem again.

 

Workaround is turning off Turbo mode.

 

Version: NX 12.0.1 MP2

4 REPLIES

Re: PostConfigurator Coolant problem

Legend
Legend
What is your Setting in Turbo mode "on" "off" "Auto" ?

Re: PostConfigurator Coolant problem

Valued Contributor
Valued Contributor

Hi @schauerm3,

 

As a newly created post processor, default Turbo mode value is set to Auto. Problem is gone if i select Off.

Re: PostConfigurator Coolant problem

Valued Contributor
Valued Contributor

Here is my (ugly) workaround, which fixes this problem and fixes "not respecting to Coolant Ude's". Note this is only a temporary way to get coolant codes back, I want to remind you that you should check results and beware of caveats. 

 

LIB_GE_command_buffer_edit_prepend MOM_rapid_move_LIB FIRST_MOVE_MILL set_coolant_fixed START_OF_FIRST_RAPID_MOVE_BASE
LIB_GE_command_buffer_edit_prepend MOM_first_move_LIB MOM_first_move_LIB_ENTRY_start set_coolant_fixed START_OF_FIRST_BASE
proc set_coolant_fixed {} {
global mom_coolant_status mom_coolant_mode
global coolant_off_event

# FIXME: Sinumerik posts fails with "Set coolant ON with program start" setting
if { ![info exists coolant_off_event] || ([info exists coolant_off_event] && $coolant_off_event != 1) } {
if { ![string compare [CONF_CTRL_coolant coolant_status] "ON" ] } { set mom_coolant_status "ON" }
}

# If status is ON, but mode is null or OFF, set mode to status
if { [info exists mom_coolant_status] && ![string compare $mom_coolant_status "ON"] && (![string compare $mom_coolant_mode ""] || ![string compare $mom_coolant_mode "OFF"])} {
set mom_coolant_mode $mom_coolant_status
}

# Output coolant on if there is no coolant OFF event
if { [info exists mom_coolant_mode] && [string length $mom_coolant_mode] && [string compare $mom_coolant_status "OFF"]} {
MOM_force once M_coolant
MOM_do_template coolant_on
}
}

proc MOM_coolant_off_ENTRY {"end"} {
global mom_coolant_status mom_coolant_mode coolant_off_event
set mom_coolant_mode "OFF"
set coolant_off_event 1
}

proc MOM_coolant_on_ENTRY {"end"} {
global mom_coolant_status mom_coolant_mode coolant_off_event
set mom_coolant_status $mom_coolant_mode
set coolant_off_event 0
}

 

 

Re: PostConfigurator Coolant problem

Valued Contributor
Valued Contributor

Hi @schauerm3,

 

Is this a known issue? I'm asking because this case can be happening in my environment only. If known, will it be fixed in next release?

Highlighted

PostConfigurator Coolant problem

Valued Contributor
Valued Contributor

Hi,

 

I've experienced strange behaviour with coolant code output.

 

Steps to reproduce problem:

  • Create a Siemens 840D post from scratch
  • Select "Coolant Status" as On
  • Create 2 tools
  • First op: Cavity mill, Follow part cut pattern, First tool
  • Second op: Cavity mill, Profile cut pattern, Second tool
  • Post process

Now you will see that there is no M8 output at the beginning of second operation.

 

If you change cut pattern to follow part in second operation, you get M8 output. (Depends on cut pattern, what?)

 

If you change second operation to Z Level Corner, same problem again.

 

Workaround is turning off Turbo mode.

 

Version: NX 12.0.1 MP2

NX CAM Postprocessor Group
NX CAM Postprocessor Group

Members (94)