Cancel
Showing results for 
Search instead for 
Did you mean: 

3D Models not Showing Correctly

Creator
Creator

I am having an issue where parts I am creating are not appearing correctly on my screen.  It is almost as if I have a specified "cube" area that I am given to design something in.  Should my object be larger than this invisible "cube", the designed object becomes cut off.  Very confusing, I know.  I have attached a short video to give an idea of what I mean.

 

I've spent entirely too much time in my settings trying to figure this out and I'm at a loss.  Any help is greatly appreciated.

 

Thanks!

-Tyler

6 REPLIES

Re: 3D Models not Showing Correctly

Valued Contributor
Valued Contributor

Trips a lot of ppl here too, but has simple fix: just do a Fit !

Dan Iorga
Sulzer Pumps US

Re: 3D Models not Showing Correctly

Creator
Creator

Ha!  What a ridiculous problem...  Thanks for your help!

Re: 3D Models not Showing Correctly

Valued Contributor
Valued Contributor
Yeah, you'd think the program is smarter that that but somehow it's not...
Dan Iorga
Sulzer Pumps US

Re: 3D Models not Showing Correctly

Siemens Phenom Siemens Phenom
Siemens Phenom

This is not a 'problem' per se, just that graphically you are always looking at the contents of a 'cube', just that most of the time the 'cube' is larger than your model but it's still there nonetheless.  Occasionally, often during the editing of a model, or when adding large Components to a smaller Assembly, the user might change the size of the model in such a way that parts of it extends outside one or more sides of the cube.  Now while it's possible to automatically update the 'cube' whenever the model size changes, that will add overhead and most of time it would be a total waste of CPU resources and if we stopped to first check to see if we really needed to change the size of the 'cube', that would add even more overhead.  So what we do is nothing.  We just assume that the user will be performing a 'Fit' operation every now and then and so we wait and recalculate the 'cube' whenever you do.  It may not appear to be all that elegant, but it gets the job done and the few times it noticed, it's easy to resolve, as you've already discovered.

John R. Baker, P.E. (ret)
EX-Product 'Evangelist'
Irvine, CA

Re: 3D Models not Showing Correctly

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Is there a way to turn off it? I've had a lot of times that... And sometimes zoom fit didn't works fine.

Re: 3D Models not Showing Correctly

Siemens Phenom Siemens Phenom
Siemens Phenom

Not sure what you're asking to "turn off".  It's not like the 'cube' is optional.  It will ALWAYS be there, period.  The graphical working space is finite, and for performance and display quality reasons, it's best that this space be no larger than it absolutely needs to be.  And as has been stated in the past, in this case, years ago, NX already addresses this issue whenever the user selects the display 'Fit' operation.

John R. Baker, P.E. (ret)
EX-Product 'Evangelist'
Irvine, CA