Cancel
Showing results for 
Search instead for 
Did you mean: 

Annoying mouse behaviour on mac port.

Experimenter
Experimenter

Hi,

 

I have recently installed NX10 on my mac (Yosemite). I run this with the XQuartz 2.7.8 version and openmotif 2.1.32.

 

It runs rather ok, but there are some issues wich I guess is due to the mac port. Mostly they are minor issues, but there is one I realy do hope there is something I can fix. 

 

For every click I intend to do i have to click twice, not a dubble click, just twice. If I want to start a new sketch, I need to press the icon first once, then again for it to open. Then i need to press the plane one, then again to actually select it.

Is there some way to set it so I can instantly select stuff. It is really annoying and since I am a NX rookie I do hope its my lack of knowledge rather than the port wich is the problem. 

 

Other than that, does anyone have any experience with running NX10 in the XQuartz enviroment. It seems to be some what unstable.

 

Best regards

Anders

 

1 REPLY

Re: Annoying mouse behaviour on mac port.

Siemens Phenom Siemens Phenom
Siemens Phenom
This 'might' be the issue, as found in the Release Notes:

Mouse focus policies

The X11 mouse focus policy specifies how the mouse advises X11 on which window is active and can receive keystrokes. The Click-through Inactive Windows and Focus Follows Mouse operations are often preferred to the X11 defaults.

In the X11 bundled with Lion, the mouse focus policies are set by choosing X11→Preferences, Windows tab. The Windows tab contains the following options:

•Click-through Inactive Windows


•Focus Follows Mouse


•Focus On New Windows


You must restart X11 for a change to take effect. Note that the setting applies only to the user's own preferences, not to the system wide preferences. Refer to the quartz-wm man page for details.