cancel
Showing results for 
Search instead for 
Did you mean: 

Anti Aliasing in NX 8.5

Experimenter
Experimenter

It seems that NX 8.5 doesn't use the Anti Aliasing functions that my Nvidia Quadro P4000 offers. See screenshots below. Even after going into the Nvidia control panel and doing an "override" on the 3D settings of NX (setting Antialiasing to max) it shows now improvement in line quality.

 

However, going into the NX settings (Preferences > Visualisation > Visual)  and turning off "Line Antialiasing" as well as "Full Scene Antialiasing" results in an even uglier line quality.

 

How can I improve line quality further?

 

 

2 REPLIES

Re: Anti Aliasing in NX 8.5

Genius
Genius
Your images are so small in size, it's impossible to tell the differences you're describing using them.

What is the root of your issue - is it how model edges appear in shaded mode or how a 2D line appears? I ask because a model that has a low facet or shaded tolerance will appear to be faceted and have jagged edges and changing the antialiasing isn't going to help that very much compared to changing the shading tolerances (IMO).

I've never had to turn on antialiasing to improve shaded model or model edge quality unless doing some screen captures of small, detailed areas. I would point you to the specific area where those shaded model settings are, but I believe they've changed since NX8.5 - if not, look under Preferences -> Visualization -> Faceting.

Keep in mind, the higher the quality, the longer it will take to shade the model.
-Tim

Re: Anti Aliasing in NX 8.5

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

@JvdP:

 

As @TimF mentioned, it's really hard to tell the issue from the small images, but it does seem that you have some "stair step" of the black edges in the last image?

 

For that, I would look at the Edge settings in the same Perference where you set Anti-Alias. Make sure it's set to "Smooth". On my laptop, there seems to be subtle change when I toggle this, but not a huge one (not like the "steps" seens when Anti-Alias is OFF in NX).

 

I have an NVIDIA Quadro M1000M, so different card, but in my settings, the Anti-Alias are mostly "Application-Controlled". Setting to "Override" seems like it would tell the card to do what it wants, instead of having NX tell the card what it needs?

 

The other thing that comes to mind (which may not matter) is that the P4000 seems to be pretty new while you're on an old NX version that does not even support Win 10, so maybe there's some conflicting new technology you are dealing with?

 

HIH.