Cancel
Showing results for 
Search instead for 
Did you mean: 

Assembly cut problem

Valued Contributor
Valued Contributor

I have an assembly that after welded has to be machined (a lot of different operations)

 

I represent it in NX by assembly cut but now I have to make some modifications and when modifying the components, some bodies in the assembly are not modifying. I have tryied by deleting the assembly cuts and then the bodies update, but now I cant create new assembly cut to those components because it says it cant promote the body.

8 REPLIES

Re: Assembly cut problem

Siemens Phenom Siemens Phenom
Siemens Phenom

I have validated this and no problem for me to update the component geometry at part level and re creating the assembly cut.

 



I have tryied by deleting the assembly cuts and then the bodies update, but now I cant create new assembly cut to those components because it says it cant promote the body.

Does NX display such a message dialog?

Regards,
Ganesh

Re: Assembly cut problem

Siemens Phenom Siemens Phenom
Siemens Phenom

I tested the behavior too but couldn't come up with a reason for the behavior.  I originally suspected it might be related to Delayed Interpart Updates and/or Promotions being disabled, but the Assembly Cut still works with promotions disabled, and @Javiduc states that only "some" components are not updating, so delayed updates is unlikely.  It sounds like it's interpart related (linked components or promotions) but we definitely need more information - unless the problem has since been resolved.

One common option that users tend to overlook is the Load Interpart Data checkbox on the Assembly Load Options.  It needs to be checked whenever dealing with WAVE, promotions, interpart expressions, positioning constraints - which all fall into the "interpart" category (Load Parents should also be set to Immedate or All Levels).

 

Screenshot - 6_12_2017 , 11_00_31 AM.png

 

Regards, Ben

Re: Assembly cut problem

Valued Contributor
Valued Contributor

I hadn't checked load interpart data, but I reworked the assembly so I cant check if it was the problem. I have checked it now and I will see what happens in future. Thanks

 

By the way, in a similar assembly, I created a sketch, then an extrusion, and then an assembly cut. Now when I edit the sketch I cant see the geometry of the part I cut in the assembly cut, but I need it to modify the lines. The same happens with the extrusion, I would like to see the part promoted by the assembly in order to edit and set the proper depth of the extrusion.  I cant see the the component even making the extrusion or the sketch current feature

Re: Assembly cut problem

Siemens Phenom Siemens Phenom
Siemens Phenom

For the Sketch, right mouse click the feature in the Part Navigator and choose "Edit".

For the Extrusion, right mouse click the feature in the Part Navigator and choose "Edit Parameters".

 

The reason you don't see the promoted geometry is because you're using "Edit with Rollback".  As the geometry is promoted you don't have the option to show/hide the parent geometry similar to how you can with WAVE.

 

Regards, Ben

Re: Assembly cut problem

Valued Contributor
Valued Contributor

If I edit the component part that is promoted making it work part, how can I use the geometry in the component part to for example move face with syncronous?

Re: Assembly cut problem

Siemens Phenom Siemens Phenom
Siemens Phenom
If you make the component the work part, you're still working "in context" of the assembly, therefore, you still see the promoted instance of the component. In order to make a synchronous change to the component you'll need to make it the displayed part. Alternatively, use the synchronous command on the promoted geometry at the assembly level.

Re: Assembly cut problem

Valued Contributor
Valued Contributor

I need to edit the geometry of the original part at part level because I need to make a drafting with this geometry in order to manufacture this part before welding, I cant modify it at assembly level. I would like to edit the part geometry in assembly environment in order to take as reference to align lines, holes... I now I can make wave link at assembly environment and then make part visible, but it is a bit slow (I was used to edit it in assemblies).

 

By the way I have attach a file where asembly cut doesnt update the geometry of the part. The line I circled in red color is the old geometry

old geometry.PNG

What I am doing wrong here? Thanks in advance

 

 

Re: Assembly cut problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Javiduc,

 

That's odd behavior.  It's almost as though the promotion has been set to "At Timestamp".  Please contact GTAC and report this issue.  I was able to get the Assembly Cut's to update by deleting Unite(9) and then editing Extrude(8) and changing the Boolean from None to Unite.

 

Regards, Ben