Cancel
Showing results for 
Search instead for 
Did you mean: 

Decimal Character in Sketch Dimensions

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

All my sketch dimensions have commas where there should be decimal points. This happens regardless of whether the part is created with english or metric dimensions. I've tried changing any number of settings in the Customer Defaults to no avail. Can someone please steer me in the right direction? Thanks in advance.

12 REPLIES

Re: Decimal Character in Sketch Dimensions

Siemens Phenom Siemens Phenom
Siemens Phenom

What version of NX are you working with?  The appearance of sketch dimensions is actually controlled by the annotation and dimension settings for your part.  For NX 8.5 & below, these settings are located in the Annotation Preferences dialog.  For NX 9 & up they're located in the Drafting Preferences dialog. 

 

In 8.5, the setting that controls the decimal character is located on the Units tab of the Annotation Preferences dialog.

 

In 9.0 the setting is called Decimal Delimiter, and it's located in the  Dimension->Text->Units node of the Drafting Preferences dialog

Re: Decimal Character in Sketch Dimensions

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

Thanks for the tip, that did it. I wouldn't have thought to look in the Drafting preferences for control over an aspect of a sketch in the Modeling application.

Re: Decimal Character in Sketch Dimensions

Genius
Genius

This is only for the session, how can I change this in customer defaults permanently.

Re: Decimal Character in Sketch Dimensions

Gears Phenom Gears Phenom
Gears Phenom

Customer Defaults, Drafting, General, Customize Standarad, Annotation.  Decimal Point Character.

-Dave
NX 11 | Teamcenter 11 | Windows 10

Re: Decimal Character in Sketch Dimensions

Genius
Genius

Thank you!

How can I change number of decimal places behind decimal point, in Customer Defaults?

Re: Decimal Character in Sketch Dimensions

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@Aleksa wrote:

This is only for the session, how can I change this in customer defaults permanently.


Actually, it is a part setting. If you use a template to start a new file, you will need to open the template file(s) and change the setting there then save the file. Files created from the modified/saved template will have the correct setting. To change the file setting, do not go into customer defaults but rather go to the menu -> Preferences -> drafting.

 

The change in the customer defaults will only apply if you choose New file -> blank. Changing the customer default value will not change existing files (such as templates).

Re: Decimal Character in Sketch Dimensions

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@Aleksa wrote:

Thank you!

How can I change number of decimal places behind decimal point, in Customer Defaults?


 

What version of NX?

In NX 9 the customer default options can be found at Drafting -> annotation -> dimensions

 

The preferences for an existing file can be found in (switch to drafting application) menu -> preferences -> drafting ->

  • Dimension -> Text -> units (main text number of decimal places)
  • Dimension -> tolerance (tolerance text number of decimal places)
  • Dimension -> dual (dual dimension number of decimal places)

 

Changing the preferences for an existing file will only affect newly created dimensions. If there are existing dimensions in the drawing, you will also need to modify the style of those (you can select multiple dimensions and modify the common properties simultaneously).

Re: Decimal Character in Sketch Dimensions

Genius
Genius

Thank you very much for the prompt reply!

Re: Decimal Character in Sketch Dimensions

Experimenter
Experimenter
I'm using NX10 and i want to change to number of decimal places for dimension in Drafting but i kept getting an error "Invalid zone font label".

This is what i did: Menu, preferences, drafting, dimension, text, units: Units: inches, Decimal Places: 3, Fraction Denominator: 1, Decimal Delimiter: period, Check "show trailing zero"

I really appreciate if you could help