Cancel
Showing results for 
Search instead for 
Did you mean: 

Diametral Reference dimensions

Experimenter
Experimenter

Simple question..... why does NX9 now put the diameter symbol outside the reference brackets of a reference dimension!!! this is not in line with any draughting standard (ISO or ASME) that I am aware of. also how do you correct it without adding appeded text to add reference brackets ??

 

This is yet another frustrating change imposed by NX9 that is most annoying!!!

Seems to me that NX 9 has been created to increase problems not solve design/draughting issues for UG users!!!

 

Apologies for the rant but with NX9 I now spend wasted time trying to find commands that before were logically placed and now have been moved elsewhere OR renamed for no apparent reason!!!

 

11 REPLIES

Re: Diametral Reference dimensions

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

In the dimension settings -> reference -> Include, change the option to "prefix".

 

Change this option in your part settings / template part settings / customer defaults as needed to affect newly created dimensions and newly created parts.

Re: Diametral Reference dimensions

Experimenter
Experimenter

So I have done this in my drafting standard (NX 10), but it still isnt including the diameter symbol in the parentheses? I do not know how to get it to stick!  Been trying to get it working for a few hours now. 

Re: Diametral Reference dimensions

Creator
Creator

If you double click on the dimension and go to Settings and select the Reference group on the left, you can select "Prefix" from the Include drop down menu.  This will put the diameter symbol inside the reference brackets.

 

There's a similar option to do this in Drafting Preferences Under Dimension - Reference, but that didn't work for me when I tried it.  Maybe you'll have better luck.  Otherwise, the first method I tried did work.

 

Good luck,

 

Matt

Re: Diametral Reference dimensions

Creator
Creator

I investigated more, and the Drafting Preferences option only works if you check the "Show as Reference Dimension" box above the drop down, and in that case, all of your dimensions appear as reference.  That seems somewhat unhelpful.  For now, maybe you'll have to go on a dimension by dimension basis and address them as I described by clicking on the individual dimension properties.

Re: Diametral Reference dimensions

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

To change an existing dimension, you will need to adjust the settings of that individual dimension. Changing the option in preferences -> drafting changes the default option and will affect any new dimensions created in the part (but will not update existing dimensions). If you want this as the default for all new parts, open your drawing template part and make the same change in preferences -> drafting and save the template. Any new parts created from this template will inherit the setting from the template.

 

Are you saying that you changed the setting in preferences -> drafting and newly created dimensions did not follow the new setting? If so, report this to GTAC; newly created dimensions (in this part) are supposed to honor the settings in preferences -> drafting.

Re: Diametral Reference dimensions

Creator
Creator

I didn't see that the original poster of this topic started the topic nearly two years ago when I posted my resonse.  For some reason it was at the top of my feed, even before topics posted today....  Not sure why that happened but I'm guessing this issue is less critical to the original poster than it once was.  Sorry about that.

 

To answer your questions below, however...

 

What was behaving strangely for me when I investigated this is that if you go, under Preferences->Drafting and then to Dimension->Reference, in NX 9, the top option is a checkbox for "Show as Reference Dimension" and the second is a drop-down box titled "Include".

 

The checkbox is a toggle that makes it so that all dimensions, when created, are reference dimensions.

The "Include" drop down specifies what to include in the parenthesis of the reference dimension.

 

In these two options, NX is misleading because I can change the value of the "Include" drop down menu, but it does not take effect unless I have checked the "Show as Reference Dimension" box.

 

I can change the "Include" dropdown menu and click "OK" to the Drafting Preferences dialog box.  If I reopen the Drafting Preferences dialog box, the "Include" dropdown will have reset (provided the "Show as Reference Dimension" was unchecked), but I only know this if I reopen the dialog box.  Otherwise, I'm lead to believe that i changed preferences.

 

I feel like the Include drop down should be unavialable unless Show as Reference Dimension is selected.

 

 

Re: Diametral Reference dimensions

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

I would agree that the "include" option is acting strangely; I suggest reporting it to GTAC.

Re: Diametral Reference dimensions

Experimenter
Experimenter

How do I report this to GTAC? 

To clarify.  I have changed the drafting standard preference to set the preference for reference dimensions to include diameter symbols.  I have attached an image below to show.  I have applied the changes, restarted and reapplied the drafting standard.  I then try to place a diameter dimension and the symbol still shows. outside the parenthesis.  

I can get the symbol to appear inside, but like someone previously stated, it makes them all inside and if I turn off reference for a dimension and turn it back on for the next, it resets to having the diameter symbol outside the parenthesis.  

If anyone can help I would really appreciate it.  It is slowing down my drafting significantly. 

Re: Diametral Reference dimensions

Creator
Creator

cadjet1

 

You are discovering exactly what I discovered in an earlier post.

 

Whether in the Drafting Standard or in the file specific Drafting Preferences, the "Include" drop down menu only works if you have the "Show as Reference Dimension" box checked.  Checking this box is ok, but the consequence is that ALL of your dimensions will then be created as reference dimensions.

 

That you need to check the "Show as Reference Dimension" box to enable the "Include" option is unclear in the setup of the dialog box.  The "Include" option should not be available unless the "Show as Reference Dimension" box has been checked.

 

This has been fixed in NX 11, but only in the Drafting Preferences dialog box and not in the Drafting Standard dialog box.

 

Since the options in the Drafting Preferences and Drafting Standard seem to be all or nothing for reference dimensions (making no or all dimensions reference to deal with the included diameter symbol), I think your best bet for now is to just change it in the individual dimension by right clicking on the diemension, selecting Settings and changing there.

 

I'll submit the issue about the inconsistent dialog box in NX 11 to GTAC and mention it should be updated in NX 9 and 10, but I'm not sure they'll address it in the older software.