Cancel
Showing results for 
Search instead for 
Did you mean: 

Dimension line covering FCF

Pioneer
Pioneer

I'm trying to place a feature control frame below a diameter dimension.  NX doesn't automatically trim the dimension line, which is frustrating.  One solution seems to be to adjust the gap by dragging the handles, but I don't like that it adjust it on both sides - making it look uneven.  I've seen some FCFs entered as appended text using a bunch of code which seems to do the trick, but I can't find a guide on how to do that.

 

dim1.JPGdim2.jpg

______________________________
NX 11.0.2
Tc 11.2.1
7 REPLIES

Re: Dimension line covering FCF

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @AeroEng363,

 

Having created and placed the FCF, right click the FCF and choose Properties.  Select the General tab and then select the Information icon.  Scroll to the bottom of the Information window to find the Text String.  You'll see something like <&70><+><&3><+>0.011<&F><+><&90>

Enter the string into the text field of your Appended Text to see the same FCF result.

 

Regards, Ben

Re: Dimension line covering FCF

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

"I've seen some FCFs entered as appended text using a bunch of code which seems to do the trick, but I can't find a guide on how to do that."

 

In the Note dialog box, if you expand the "symbols" section and change the category to "GD&T", there are tools to help build the desired frame.

Re: Dimension line covering FCF

Pioneer
Pioneer

I'm trying to stack two FCFs under the same dimension.  In Creo we were able center them nicely like this:

Capture.JPG

 

 

 

 

 

 

 

 

 

 

 

 

In NX, adding <&80> sends the second FCF to the next line, but the whole thing shifts awkwardly to the left.  Any way around this?

Capture.JPG

______________________________
NX 11.0.2
Tc 11.2.1

Re: Dimension line covering FCF

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

It can be accomplished, though probably not as streamlined until ER 7766350 is implemented; which requests that gaps in the dimension line have different values on either side of the dimension.

 

The entire dimension is aligned using Text Justification: Center.

The first FCF was added using Appended Text: Below

The section FCF was added using FCF command and stacked with Above Gap Factor: zero

The gap under the second FCF was added using legacy User Defined Feature: GAP25 (which has to be added to the menus/ribbon using the Customize command).

 

Screenshot - 8_21_2017 , 8_22_24 AM.png

Re: Dimension line covering FCF

Pioneer
Pioneer

@BenBroad,

 

I'm not seing "GAP25" when I search under "All Commands" in the Customize window.  Is there something else I need to do?

 

Thanks

______________________________
NX 11.0.2
Tc 11.2.1

Re: Dimension line covering FCF

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

It's under "Menu > Insert > Symbol > User Defined". Drag "User Defined" into your session. Gap will be listed under "Use Symbols In: Utility Directory".

If you ever need to delete a Gap utility symbol, you will need to add "Component" back to the UI (Menu > Edit > Component).

Re: Dimension line covering FCF

Phenom
Phenom

Edit:  apparently, Ben and I were posting at the same time.

 

Insert -> Symbol -> User Defined Symbol.

(I am going by memory from this point forward)
Choose Use Symbols in: Utility Directory
standard.sbf or std.sbf

You should now see a couple of different GAP symbols - GAP25, maybe GAP50 or something else like that.

You may have to play around with the symbol size definition settings to get the gap just right.

-Tim