Cancel
Showing results for 
Search instead for 
Did you mean: 

Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Creator
Creator

Hi all,

 

I am trying to show smooth edges of the chamfer edges on angle bar stock items drawn with mechanical routing. When activating smooth edges in drawing view settings, the edges are still not showing.

 

Is there any other way to show them?

 

2019-02-15 16_06_44-NX11 (NX Setup Bergen Engines AS Prod 30.09.2018) - Drafting - [B01037964_#OR_Fo.png

 

 

Regards, Eirik

9 REPLIES 9

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Gears Phenom Gears Phenom
Gears Phenom

NX11 works for me???

 

SMOOTH.gifsmooth2.gif

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Gears Phenom Gears Phenom
Gears Phenom

Ah, it could be your blend is a soft radius.

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Gears Phenom Gears Phenom
Gears Phenom

Checked, even soft blend works for me.

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Creator
Creator
It does not seem to work for me with same settings applied.

Maybe one should model the part family profile sketches in some particular way to get these tangent edges shown, or maybe some option is not active..?

Regards,
Eirik

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Did you turn on the smooth edge option after placing the view? If so, be sure to apply the settings to the view itself and not just to the general drafting view settings. If you change the general settings, it will affect newly created views, but it won't update any existing views with the changes (each view has its own individual settings).

Highlighted

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Siemens Genius Siemens Genius
Siemens Genius

Hello,

There is a Customer Default in Routing for this.

Routing, General, Stock tab, Create Tiled Faces for Stock Bodies.  

Turn this on, and each cross section curves of the stock definition gets a separate face.  And faces at each segment rcp.

You may not care for that last part, so in NX12.0.2, there is an enviroment variable that will merge the faces along collinear path segments.  UGII_ROUTING_NEW_TILED_TOPOLOGY_OPTION=true or 1 

 

Basically this controls options to the Parasolid feature on which stock is based. 

 

(When the CD is off, parasolid makes all tangent faces a single b-surf.)

 

Thanks

Doug

 

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Creator
Creator
Hi @Doug,

I confirm that this solves the missing tangent lines!

Is there any way I can update a CAD model created prior to turning on the option in order to obtain these lines ?

Thanks!

Regards,
Eirik

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Creator
Creator
Hi again,

Figured this one out. You open "edit stock" and hit OK. This redraws the sweep model, now with tangent edges.
Maybe a faster way to update exists?

Eirik

Re: Drafting of mechanical routing stock model: Smooth edges not showing upon activation.

Siemens Genius Siemens Genius
Siemens Genius
Probably could use Transform Path and move everything to right 10 and then back 10. It would have to be two separate operations. (If you just move it back and forth within TP without an Okay, NX likely treats that as a No Op condition since nothing has really changed.)
Oh, Modeling's Feature Replay might do it. Also Routing's Stock Style, change to Detailed, Simple or Centerline and back.

Doug