Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Drafting, preference for graphics view zoom and unzoom after dimensioning.

I have looked through prefs and defaults but cannot locate any settings which control the graphics view snapping back to where it was before dimensioning.  The pref is probably right in front of me but I'm hoping a fresh look from someone else could find it.

NX 10.0.3
5 REPLIES

Re: Drafting, preference for graphics view zoom and unzoom after dimensioning.

Hello @Mould_United,

 

If I understand you question correctly. When you are dimensioning, and you cancel out the menu. The zoom goes back to the point where you started before you start dimensioning, right? This "new" behavior, was implemented a few versions ago (NX 9.0, 10.0?), To make it consistant with the behavior from other parts/menus within NX.

There is no switch/toggle/setting that can get the previous behavior back. I believe there are some ER's posted on this one. But the change was made intentionally.

 

Kind regards,

 

Dennis

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: Drafting, preference for graphics view zoom and unzoom after dimensioning.

From my experience, some of our former Solidworks users have asked about a "back to previous view" option.  I really don't know how that worked, but some of them seemed to miss it....most have adopted to using a 3D motion controller now, and have forgotten their desire for it.

 

http://help.solidworks.com/2015/English/SolidWorks/sldworks/t_previous_view.htm

-Dave
NX 9 | Teamcenter 10.1 | Windows 8.1

Re: Drafting, preference for graphics view zoom and unzoom after dimensioning.

Yes, the snapping back in the graphics window.  What it comes down to is movement in the graphics window that is not from the user.  I find the behaviour quite annoying because when I back out of a command I typically perform a different command in the same area but lo and behold NX feels it needs to snap back to a previous zoom point.  If I decide to use a different type of dimensioning the unwanted behaviour is still present.  The only way I can see to avoid this is to zoom into the desired area before clicking on a dimension type.  Modeling does not have this behaviour, and I cannot recall if it was in 9,  but please do not consider this behaviour for modeling.  It does not seem wise to have to zoom into every little area on a model before clicking a button.

NX 10.0.3
Solution
Solution
Accepted by topic author Mould_United
a week ago

Re: Drafting, preference for graphics view zoom and unzoom after dimensioning.

It has to do with how 'Undo' was implemented in Drafting.  I've always considered it a 'bug' but I could never get anyone in the Drafting group to looking into it.

 

If I were you, I'd open a PR (and ask all your friends to do the same) and perhaps you might get this fixed once and for all.

John R. Baker, P.E. (ret)
EX-Product 'Evangelist'
Irvine, CA

Re: Drafting, preference for graphics view zoom and unzoom after dimensioning.

@JohnRBaker

Thank you for your input, John.  I agree it is a bug and I'll open a PR when I have a break in programming.

NX 10.0.3