Cancel
Showing results for 
Search instead for 
Did you mean: 

Export STEP error

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

My coworker is having issues exporting files to STEP format; he gets an error message of "Symbol not found in library" or just "interrupt" and nothing is exported. We are using NX 10.0.3.5, but he has also tried with NX 9.0.3.4 (same results).

 

export_step_interrupt.pngexport_step_symbol_not_found.png

 

His log file shows an error code that doesn't help much with my troubleshooting:

 

export_step_log_error.PNG

 

I can export the files from my computer without issue. I suspect a license issue, but it appears that he has the correct bundle selected (mach 1, in his case). I didn't find anything in the solution center for this error message.

2 REPLIES 2

Re: Export STEP error

Siemens Esteemed Contributor Siemens Esteemed Contributor
Siemens Esteemed Contributor

Does "File -> Save As -> Save As Type: STEP 203 Files" return the same result?

 

The "Symbol not found in library" has been reported in the past when the exported file already exists in the folder the user was exporting to and in another case when the file being exported from had not been saved prior to the export.

 

Another issue, though this was from Importing STEP that was raising the part_foreign_step.c error, but the same scenario was reported (one user could not import) which  turned out to be a bundle selection issue.  Suggestions during that case were to check that the translators had been installed (check for existance of STEP directories in the NX install directory) and ensure that 64-bit JAVA had been installed.

 

Can the user import a STEP file?

Ben Broad | PLM Enthusiast | Siemens GCSS

NX (v17 - 1872) | Teamcenter (9 - 12)
Value Based Licensing | Adaptive UI | BETA Registration

Re: Export STEP error

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

I think this is a licensing issue. He is one of our "node-locked" users and he got a new workstation recently. I forgot to request an update to our license file. I suspect that his computer has been grabbing a floating license that doesn't have the STEP import/export capability.