cancel
Showing results for 
Search instead for 
Did you mean: 

Full keyboard does not work in touch screen mode

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hello everyone!

 

I'm testing touch screen modes in NX11 and I can't see the full keyboard. Numpad keyboard is displayed without problems, but when I press ABC on top of it, nothing is shown. What is the problem?

9 REPLIES

Re: Full keyboard does not work in touch screen mode

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Scaffold

 

What kind of device are you using, what is the OS and are you using the Windows Keyboard?  I just tested NX11 on Windows 7 and the Windows keyboard displays fine - I'm also able to resize the keyboard by dragging the edges.

 

Regards, Ben

Re: Full keyboard does not work in touch screen mode

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
I'm using a touch screen-capable laptop, Windows 10. Seen it working fine on other machines, but on mine I'm having this problem.

Re: Full keyboard does not work in touch screen mode

Siemens Phenom Siemens Phenom
Siemens Phenom

When you say you can't see the full keyboard, what's missing?

Does this article help?

 

Regards, Ben

Re: Full keyboard does not work in touch screen mode

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
Normally, full keyboard would pop up when you press ABCD button on the virtual numpad keyboard. In my case, nothing happens - numpad disappears but full keyboard does not show up.

Re: Full keyboard does not work in touch screen mode

Siemens Phenom Siemens Phenom
Siemens Phenom

Is this the Windows keyboard, or a 3rd party application?

 

The one I tested is the one that's installed with Windows that I found here: Start > All Programs > Accessories > Ease of Access > On-Screen Keyboard".  I know Sony Vaio laptops have their own on-screen keyboard which functions differently to the Windows one.  Is the keyboard only giving you problems when using NX?

Re: Full keyboard does not work in touch screen mode

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
You mean that the virtual keyboard in question is not run by NX but by Windows? It's not the NX application? If this is the case, it's kinds of news for me. I will check whether it works with other applications.

Re: Full keyboard does not work in touch screen mode

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

I mean these virtual keyboards. Are they coming from Windows or NX?

 

2017-09-13.png2017-09-13 (1).png

Re: Full keyboard does not work in touch screen mode

Siemens Legend Siemens Legend
Siemens Legend

The numeric keypad is launched by NX. The ABCD keyboard is windows standard keyboard.

Please note that it is the 'touch keyboard' you want.

 

There can be two things you can try (on Windows 10):

1. The touch keyboard does not show up because you are not in 'tablet mode', turning on tablet mode will address that (turn it on by pressing the setting tile in the notification area at the bottom right of your screen) 

2. There is an option to show the 'touch keyboard' when not in tablet mode. Turn that on. Search for the 'touch keyboard' in 'search windows' (bottom left of the screen).

 

Hope this helps and you enjoy touch mode in NX.

 

Regards, **bleep**

Re: Full keyboard does not work in touch screen mode

Siemens Phenom Siemens Phenom
Siemens Phenom

I just installed NX11 on a Windows 10 VM.  I now see the icons in you screenshots and the keyboard functions properly for me.  I wonder if your keyboard got docked somewhere in your windows session?

From Windows select "Start > Settings > Ease of Access > Keyboard" and toggle on the On-Screen Keyboard (this is an extended keyboard).  Close the Settings window and return to NX.  Open the File New dialog, select the text entry field which should invoke the numpad.  Select ABCD and make sure the extended keyboard works.  Now Exit the keyboard, select the text entry field, select ABCD on the numpad and see if the basic keyboard is restored.

 

Regards, Ben